summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:51:20 +0200
committerStefan Husmann2015-06-09 00:51:20 +0200
commit15f57a6693f329747993802b79a2c948a429e617 (patch)
tree205dc962071ce287ec5f15da1e30d362e1914160
downloadaur-15f57a6693f329747993802b79a2c948a429e617.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8c6c12fd504
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = svg2tikz-git
+ pkgdesc = set of tools for converting SVG graphics to TikZ/PGF code
+ pkgver = r201.9733751
+ pkgrel = 1
+ url = https://github.com/kjellmf/svg2tikz
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-lxml
+ optdepends = inkscape: for using the inksape extension files
+ provides = inkscape-tikz
+ conflicts = inkscape-tikz
+ replaces = inkscape-tikz-hg
+ source = git+https://github.com/kjellmf/svg2tikz
+ md5sums = SKIP
+
+pkgname = svg2tikz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6873e1772221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: max_meyer <dev@fedux.org>
+
+pkgname=svg2tikz-git
+pkgver=r201.9733751
+pkgrel=1
+pkgdesc="set of tools for converting SVG graphics to TikZ/PGF code"
+arch=('any')
+url="https://github.com/kjellmf/svg2tikz"
+license=('GPL')
+depends=('python2-lxml')
+makedepends=('git')
+provides=('inkscape-tikz')
+conflicts=('inkscape-tikz')
+replaces=('inkscape-tikz-hg')
+optdepends=('inkscape: for using the inksape extension files')
+source=("git+https://github.com/kjellmf/svg2tikz")
+md5sums=('SKIP')
+_gitname="svg2tikz"
+
+pkgver() {
+ cd "$srcdir"/"$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"/"$_gitname"
+ [[ -d build ]] || rm -rf build
+ cd $_gitname
+ for _i in inkexlib/inkex.py \
+ inkexlib/simplepath.py \
+ inkexlib/simplestyle.py \
+ extensions/tikz_export.py \
+ extensions/tikz_export.py
+ do
+ sed -i '1s+python$+python2+' ${_i}
+ done
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ _inkscape_ext="$pkgdir/usr/share/inkscape/extensions"
+ install -d "$_inkscape_ext"
+ cp ./svg2tikz/extensions/tikz_export* "$_inkscape_ext"
+}