summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMansour Behabadi2022-12-16 12:46:12 +1100
committerMansour Behabadi2022-12-16 12:46:12 +1100
commita26fb1a50c911fc4aba7da7f7dbbcdcc9e995dcc (patch)
tree934e8064245a58d1dcb23468fc5640ccef5c03c4
downloadaur-a26fb1a50c911fc4aba7da7f7dbbcdcc9e995dcc.tar.gz
initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5372339a9f8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = svglinkify-git
+ pkgdesc = Export inkscape SVGs to PDF while preserving hyperlinks.
+ pkgver = r8.2a2f4bc
+ pkgrel = 1
+ url = https://github.com/oxplot/svglinkify
+ arch = any
+ license = MIT
+ depends = qpdf>=11.1.1
+ depends = inkscape>=1.2.1
+ source = git+https://github.com/oxplot/svglinkify.git
+ sha512sums = SKIP
+
+pkgname = svglinkify-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f734187d969a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mansour Behabadi <mansour@oxplot.com>
+
+pkgname=svglinkify-git
+_pkgname=svglinkify
+pkgver=r8.2a2f4bc
+pkgrel=1
+pkgdesc='Export inkscape SVGs to PDF while preserving hyperlinks.'
+arch=('any')
+url='https://github.com/oxplot/svglinkify'
+license=('MIT')
+depends=('qpdf>=11.1.1' 'inkscape>=1.2.1')
+source=("git+https://github.com/oxplot/svglinkify.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/svglinkify"
+ echo "r$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package()
+{
+ cd "${srcdir}/svglinkify"
+ install -D svglinkify.py "${pkgdir}/usr/bin/svglinkify"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}