summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-06-21 14:05:02 +0000
committerBalló György2020-06-21 14:05:02 +0000
commitaee8d1fffbdfcbe40c6f3137a2a6a793be8c9402 (patch)
treed6787c00f8f0980161f218de9438607a1310326d
downloadaur-aee8d1fffbdfcbe40c6f3137a2a6a793be8c9402.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f8dd337aa7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = svgvi
+ pkgdesc = SVG Text Editor and Viewer
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://gitlab.com/pwmc/svgvi
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = gsvgtk
+ depends = gtksourceview3
+ source = git+https://gitlab.com/pwmc/svgvi.git#commit=09d6675810acf034cd3ef1fe069df78f74ea2854
+ sha256sums = SKIP
+
+pkgname = svgvi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5b3dd96590f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=svgvi
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="SVG Text Editor and Viewer"
+arch=(x86_64)
+url="https://gitlab.com/pwmc/svgvi"
+license=(GPL3)
+depends=(gsvgtk gtksourceview3)
+makedepends=(cmake git meson vala)
+checkdepends=()
+optdepends=()
+_commit=09d6675810acf034cd3ef1fe069df78f74ea2854 # tags/1.6.0^0
+source=("git+https://gitlab.com/pwmc/svgvi.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}