summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphiresky2018-07-19 19:44:19 +0200
committerphiresky2018-07-19 19:44:26 +0200
commit57e944818fee2e32cc0a6e29d60513d0111a3cac (patch)
tree72714f4929f0879f665c35c442f5814265bd7fe2
parentbd57cf157d97e253dd23399d4276bc6d32d2f4ca (diff)
downloadaur-57e944818fee2e32cc0a6e29d60513d0111a3cac.tar.gz
disable strip, add missing dep
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b59d932aa73..0d3014dcdffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 18 10:36:09 UTC 2018
+# Thu Jul 19 17:44:22 UTC 2018
pkgbase = svp
pkgdesc = SmoothVideo Project 4 (SVP4)
pkgver = 4.2.0.137
- pkgrel = 1
+ pkgrel = 2
url = https://www.svp-team.com/wiki/SVP:Linux
install = svp.install
arch = x86_64
@@ -12,12 +12,14 @@ pkgbase = svp
depends = libmediainfo
depends = qt5-svg
depends = qt5-script
+ depends = qt5-declarative
depends = vapoursynth
depends = libusb
depends = xdg-utils
depends = lsof
optdepends = mpv-git: needed for mpv vapoursynth support
optdepends = ocl-icd: for GPU acceleration
+ options = !strip
source = https://gist.githubusercontent.com/phiresky/1e2cbd30bed4e5978771af232d11afd1/raw/svp4-4.2.0.137.tbz2
sha256sums = f678faedddde753bca3373f109c358fb166a7887d68d8484467bb06e031fb3eb
diff --git a/PKGBUILD b/PKGBUILD
index e26359219bf0..700ff2faf0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: phiresky <phireskyde+git@gmail.com>
pkgname=svp
pkgver=4.2.0.137
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="SmoothVideo Project 4 (SVP4)"
arch=('x86_64')
url="https://www.svp-team.com/wiki/SVP:Linux"
license=('custom')
groups=()
-depends=(libmediainfo qt5-svg qt5-script vapoursynth libusb xdg-utils lsof)
+depends=(libmediainfo qt5-svg qt5-script qt5-declarative vapoursynth libusb xdg-utils lsof)
makedepends=(p7zip)
checkdepends=()
optdepends=(
@@ -19,7 +19,7 @@ provides=()
conflicts=()
replaces=()
backup=()
-options=()
+options=(!strip)
install=${pkgname}.install
changelog=
source=("https://gist.githubusercontent.com/phiresky/1e2cbd30bed4e5978771af232d11afd1/raw/svp4-$pkgver.tbz2")
@@ -56,6 +56,7 @@ package() {
mv "$srcdir/extracted/licenses" "$pkgdir/usr/share/licenses/$pkgname"
fi
mv "$srcdir/extracted/"* "$pkgdir/opt/$pkgname"
+ rm "$pkgdir/opt/$pkgname/extensions/libsvpcode.so"
ln -s "/opt/$pkgname/SVPManager" "$pkgdir/usr/bin/SVPManager"
chmod -R +rX "$pkgdir/opt/svp" "$pkgdir/usr/share"
}