summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 21:52:23 -0400
committerXiao-Long Chen2015-06-08 21:52:23 -0400
commit42f535067ffb887059cf3824f2bbc3f409726778 (patch)
treef5b78fd243979070ac5571c83aecf38a178963bf
downloadaur-42f535067ffb887059cf3824f2bbc3f409726778.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab4e4afa256b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = svrcore
+ pkgdesc = Secure PIN handling using NSS crypto
+ pkgver = 4.0.4
+ pkgrel = 4
+ url = https://wiki.mozilla.org/LDAP_C_SDK
+ arch = i686
+ arch = x86_64
+ license = MPL
+ depends = nspr
+ depends = nss
+ options = !libtool
+ source = ftp://ftp.mozilla.org/pub/mozilla.org/directory/svrcore/releases/4.0.4/src/svrcore-4.0.4.tar.bz2
+ sha512sums = 4a63e2618ef8f508e71adf212eefae56e3c9d9898b924f405399bb99793de57bd178a3417f9e837c474e7960b6eb8a3cbe775b420c8fecbd974e89b4196b78fc
+
+pkgname = svrcore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b40b8bba840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=svrcore
+pkgver=4.0.4
+pkgrel=4
+pkgdesc="Secure PIN handling using NSS crypto"
+arch=(i686 x86_64)
+license=(MPL)
+url="https://wiki.mozilla.org/LDAP_C_SDK" # TODO there is a mention of it, but does anyone really know?
+depends=(nspr nss)
+options=(!libtool)
+source=("ftp://ftp.mozilla.org/pub/mozilla.org/directory/${pkgname}/releases/${pkgver}/src/${pkgname}-${pkgver}.tar.bz2")
+sha512sums=('4a63e2618ef8f508e71adf212eefae56e3c9d9898b924f405399bb99793de57bd178a3417f9e837c474e7960b6eb8a3cbe775b420c8fecbd974e89b4196b78fc')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --disable-static
+ if [[ "$CARCH" = 'x86_64' ]]; then
+ make USE64=1
+ else
+ make
+ fi
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+}