summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2020-08-20 14:24:39 +0800
committerSukanka2020-08-20 14:24:39 +0800
commit7f9e745e4366594edd087203e7b75d6ddf8bde86 (patch)
tree0a28b716158c710dc47b1ae225cca9e6d14e241d
parent6b8e3a5ac9abaff34de80fa825c728bd382bdb08 (diff)
downloadaur-7f9e745e4366594edd087203e7b75d6ddf8bde86.tar.gz
update version to 1.0.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--svstudio-bin.install20
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54651b12fe89..5ca5adf72f6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = svstudio-bin
pkgdesc = Synthesizer V Studio, a high-quality singing synthesis software.
- pkgver = 1.0.4
- pkgrel = 2
+ pkgver = 1.0.5
+ pkgrel = 1
url = https://dreamtonics.com
+ install = svstudio-bin.install
arch = x86_64
license = custom
depends = libcurl-gnutls
depends = webkit2gtk
provides = svstudio
- source = svstudio.zip::https://dreamtonics.com/synthv/download/Synthesizer%20V%20Studio%20Basic/svstudio-basic-linux64-1.0.4.zip
+ source = svstudio-1.0.5.zip::https://dreamtonics.com/synthv/download/Synthesizer%20V%20Studio%20Basic/svstudio-basic-linux64-1.0.5.zip
source = svstudio.svg
- sha512sums = ae4a2b7d4b7c1f1e7f2600b26542221d56abf325bbe88e239391f084682a9a120f6feec7bc214f41949e8927c16b1ce8203b839f944f8139888cb46baaa78200
+ sha512sums = 8a61404821130a0adb15d4b547cbd0290372d0740d933d10a7fcb9e85ea9d24f47de0b2694e7e1804de658ace34f18be679cf69a55dcd45dcf64ec6699ae4190
sha512sums = d361e7557d8aa11dbeea466ed1e60c8c40166788ef9a344c0a7954ded672f408c26d1ce37dc3ba7cb745efbcd41896be9db71f63f51c2a4d59ab62c74ea69998
pkgname = svstudio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0ed9a99b2008..13d5fde8a0fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sukanka<su975853527 AT gmail.com>
pkgname=svstudio-bin
_pkgname=svstudio
-pkgver=1.0.4
-pkgrel=2
+pkgver=1.0.5
+pkgrel=1
pkgdesc="Synthesizer V Studio, a high-quality singing synthesis software."
url="https://dreamtonics.com"
arch=('x86_64')
@@ -10,15 +10,15 @@ license=('custom')
depends=('libcurl-gnutls' 'webkit2gtk')
provides=("svstudio")
source=(
- "${_pkgname}.zip::https://dreamtonics.com/synthv/download/Synthesizer%20V%20Studio%20Basic/svstudio-basic-linux64-${pkgver}.zip"
+ "${_pkgname}-${pkgver}.zip::https://dreamtonics.com/synthv/download/Synthesizer%20V%20Studio%20Basic/svstudio-basic-linux64-${pkgver}.zip"
'svstudio.svg'
)
sha512sums=(
- 'ae4a2b7d4b7c1f1e7f2600b26542221d56abf325bbe88e239391f084682a9a120f6feec7bc214f41949e8927c16b1ce8203b839f944f8139888cb46baaa78200'
+ '8a61404821130a0adb15d4b547cbd0290372d0740d933d10a7fcb9e85ea9d24f47de0b2694e7e1804de658ace34f18be679cf69a55dcd45dcf64ec6699ae4190'
'd361e7557d8aa11dbeea466ed1e60c8c40166788ef9a344c0a7954ded672f408c26d1ce37dc3ba7cb745efbcd41896be9db71f63f51c2a4d59ab62c74ea69998'
)
-
+install=svstudio-bin.install
package(){
cd "${srcdir}/Synthesizer V Studio Basic"
@@ -27,10 +27,13 @@ package(){
ln -s /opt/${_pkgname}/synthv-studio ${pkgdir}/usr/bin/svstudio
mv clf-data ${pkgdir}/opt/${_pkgname}
+ mv databases ${pkgdir}/opt/${_pkgname}
mkdir -p ${pkgdir}/usr/share/licenses/${_pkgname}
mv license-*.txt ${pkgdir}/usr/share/licenses/${_pkgname}
mv docs/third-party ${pkgdir}/usr/share/licenses/${_pkgname}
+ mkdir -p ${pkgdir}/opt/${_pkgname}/docs
+ ln -s /usr/share/licenses/${_pkgname}/third-party ${pkgdir}/opt/${_pkgname}/docs/third-party
mv fonts ${pkgdir}/opt/${_pkgname}
@@ -39,11 +42,12 @@ package(){
echo '''[Desktop Entry]
Name=svstudio
Comment=a high-quality singing synthesis software
-Exec=svstudio
+Exec=svstudio %f
Terminal=false
Type=Application
Icon=/usr/share/icon/hicolor/scalable/apps/svstudio.svg
-Categories=Utility;
+MimeType=application/tup;
+Categories=AudioVideo;Audio;AudioVideoEditing;
Name[zh_CN.utf8]=svstudio.desktop
''' > svstudio.desktop
diff --git a/svstudio-bin.install b/svstudio-bin.install
new file mode 100644
index 000000000000..ebb177c5f68f
--- /dev/null
+++ b/svstudio-bin.install
@@ -0,0 +1,20 @@
+post_install(){
+ chmod -R o+w /opt/svstudio
+}
+
+pre_upgrade(){
+ chmod -R o-w /opt/svstudio
+}
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ pre_upgrade
+}
+
+post_remove() {
+ if [ -d /opt/svstudio ]; then
+ rm -rf /opt/svstudio/
+ fi
+}