summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-06-11 09:06:15 +0200
committerCarsten Feuls2015-06-11 09:06:15 +0200
commit89580dacdb9ce3373209110c074bdcaead7d5718 (patch)
tree0ac19d3ef30413175d7cace51fa0a5770a841658
downloadaur-89580dacdb9ce3373209110c074bdcaead7d5718.tar.gz
Initial import
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD49
-rw-r--r--remotetrx.service14
-rw-r--r--svxlink.install41
-rw-r--r--svxlink.service15
5 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..398e9b464814
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = svxlink
+ pkgdesc = Echolink Software to provide Ham Radio Voip Operations
+ pkgver = 14.08.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/svxlink/
+ install = svxlink.install
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = cmake
+ depends = alsa-utils
+ depends = alsa-lib
+ depends = libsigc++
+ depends = gsm
+ depends = libgcrypt
+ depends = popt
+ depends = tcl
+ depends = speex
+ depends = opus
+ optdepends = svxlink-sounds-en_us-heather-8k: provides speech sound files in medium quality
+ optdepends = svxlink-sounds-en_us-heather-16k: provides speech sound files in high quality
+ backup = etc/svxlink/svxlink.conf
+ backup = etc/svxlink/TclVoiceMail.conf
+ backup = etc/svxlink/remotetrx.conf
+ backup = etc/svxlink/svxlink.d/ModuleDtmfRepeater.conf
+ backup = etc/svxlink/svxlink.d/ModuleEchoLink.conf
+ backup = etc/svxlink/svxlink.d/ModuleHelp.conf
+ backup = etc/svxlink/svxlink.d/ModuleMetarInfo.conf
+ backup = etc/svxlink/svxlink.d/ModuleParrot.conf
+ backup = etc/svxlink/svxlink.d/ModulePropagationMonitor.conf
+ backup = etc/svxlink/svxlink.d/ModuleSelCallEnc.conf
+ backup = etc/svxlink/svxlink.d/ModuleTclVoiceMail.conf
+ source = https://github.com/sm0svx/svxlink/archive/14.08.1.tar.gz
+ source = svxlink.service
+ source = remotetrx.service
+ sha256sums = c631c8073d34638d0762bd246e2fa0f315a640a45f10923e6075720bd4245a82
+ sha256sums = adc29c81df1794b62bd47202af388397c886cc86a95fa05b3446b3a93a1b3a7c
+ sha256sums = 41adf7f9863f1ea3013b079e628455a22c29d1b369d174bd19905334c9c31543
+
+pkgname = svxlink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b59f44ecab3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Carsten Feuls (DL1CAF) 'Der Techniker' <dl1caf@vfdb.org>
+# Contributer: Amateurfunk Station der Hochschule Niederrhein (DF0FN) <df0fn@hs-niederrhein.de>
+pkgname=('svxlink')
+pkgver="14.08.1"
+pkgrel=1
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="http://sourceforge.net/projects/svxlink/"
+license=('GPL')
+source=("https://github.com/sm0svx/${pkgname}/archive/${pkgver}.tar.gz"
+ "svxlink.service"
+ "remotetrx.service")
+sha256sums=('c631c8073d34638d0762bd246e2fa0f315a640a45f10923e6075720bd4245a82'
+ 'adc29c81df1794b62bd47202af388397c886cc86a95fa05b3446b3a93a1b3a7c'
+ '41adf7f9863f1ea3013b079e628455a22c29d1b369d174bd19905334c9c31543')
+depends=('alsa-utils' 'alsa-lib' 'libsigc++' 'gsm' 'libgcrypt' 'popt' 'tcl' 'speex' 'opus')
+makedepends=('cmake')
+pkgdesc="Echolink Software to provide Ham Radio Voip Operations"
+optdepends=('svxlink-sounds-en_us-heather-8k: provides speech sound files in medium quality'
+ 'svxlink-sounds-en_us-heather-16k: provides speech sound files in high quality')
+backup=('etc/svxlink/svxlink.conf'
+ 'etc/svxlink/TclVoiceMail.conf'
+ 'etc/svxlink/remotetrx.conf'
+ 'etc/svxlink/svxlink.d/ModuleDtmfRepeater.conf'
+ 'etc/svxlink/svxlink.d/ModuleEchoLink.conf'
+ 'etc/svxlink/svxlink.d/ModuleHelp.conf'
+ 'etc/svxlink/svxlink.d/ModuleMetarInfo.conf'
+ 'etc/svxlink/svxlink.d/ModuleParrot.conf'
+ 'etc/svxlink/svxlink.d/ModulePropagationMonitor.conf'
+ 'etc/svxlink/svxlink.d/ModuleSelCallEnc.conf'
+ 'etc/svxlink/svxlink.d/ModuleTclVoiceMail.conf')
+install=svxlink.install
+
+build(){
+ cd "${srcdir}/${pkgname}-${pkgver}/src"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DLOCAL_STATE_DIR=/var -DUSE_QT=NO ..
+ make
+ make doc
+}
+
+package(){
+ make -C ${srcdir}/${pkgname}-${pkgver}/src/build DESTDIR="${pkgdir}" install
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ mkdir -p "${pkgdir}/var/spool/svxlink"
+ # svxlink systemd service file
+ cp ${srcdir}/svxlink.service ${pkgdir}/usr/lib/systemd/system
+ cp ${srcdir}/remotetrx.service ${pkgdir}/usr/lib/systemd/system
+}
diff --git a/remotetrx.service b/remotetrx.service
new file mode 100644
index 000000000000..e242243d2c42
--- /dev/null
+++ b/remotetrx.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Echolink Software Remotetrx
+After=network.target
+After=sound.target
+
+[Service]
+Type=simple
+User=svxlink
+Group=svxlink
+ExecStart=/usr/bin/remotetrx
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/svxlink.install b/svxlink.install
new file mode 100644
index 000000000000..06aa8926fe87
--- /dev/null
+++ b/svxlink.install
@@ -0,0 +1,41 @@
+post_install(){
+/usr/bin/egrep -i "^svxlink" /etc/group >> /dev/zero
+if [ ! $? -eq 0 ]
+then
+ groupadd svxlink
+fi
+
+/usr/bin/egrep -i "^svxlink" /etc/passwd >> /dev/zero
+if [ ! $? -eq 0 ]
+then
+ useradd svxlink -m -d /var/spool/svxlink -g svxlink -G uucp,tty,audio
+
+fi
+chown -R svxlink:svxlink ${pkgdir}/var/spool/svxlink
+}
+
+
+pre_remove(){
+systemctl stop svxlink.service
+}
+
+
+post_remove(){
+/usr/bin/egrep -i "^svxlink" /etc/passwd >> /dev/zero
+if [ $? -eq 0 ]
+then
+ userdel svxlink
+fi
+
+/usr/bin/egrep -i "^svxlink" /etc/group >> /dev/zero
+if [ $? -eq 0 ]
+then
+ groupdel svxlink
+fi
+}
+
+post_upgrade(){
+gpasswd -a svxlink uucp
+gpasswd -a svxlink tty
+gpasswd -a svxlink audio
+}
diff --git a/svxlink.service b/svxlink.service
new file mode 100644
index 000000000000..10c3f88e9449
--- /dev/null
+++ b/svxlink.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Echolink Software
+After=network.target
+After=sound.target
+
+[Service]
+Type=simple
+User=svxlink
+Group=svxlink
+ExecStart=/usr/bin/svxlink
+Restart=always
+
+
+[Install]
+WantedBy=multi-user.target