summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Porte2017-01-28 16:00:15 +0100
committerRomain Porte2017-01-28 16:00:15 +0100
commit6842d55d31d8ff80132a2b1b91191ff97276f422 (patch)
tree45bdd5e170fe7a764e56f188881749376340c2f2
downloadaur-6842d55d31d8ff80132a2b1b91191ff97276f422.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
-rw-r--r--sw4stm323
-rw-r--r--sw4stm32.desktop10
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..873598238acf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sw4stm32
+ pkgdesc = SystemWorkbench for STM32
+ pkgver = v1.8
+ pkgrel = 1
+ url = http://www.openstm32.org/System+Workbench+for+STM32
+ arch = x86_64
+ license = unknown
+ depends = desktop-file-utils
+ noextract = install_sw4stm32_linux_64bits-v1.8.run
+ source = http://www.ac6-tools.com/downloads/SW4STM32/install_sw4stm32_linux_64bits-v1.8.run
+ source = sw4stm32
+ source = sw4stm32.desktop
+ md5sums = f4cf8d73b867cf7c7f261a8bfea3a8b2
+ md5sums = 2cb47631f9c17ae30890001eec765107
+ md5sums = fab1a998b1f24153827bfb4d9013240f
+
+pkgname = sw4stm32
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cd762900c00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Romain Porte <microjoe@microjoe.org>
+
+pkgname=sw4stm32
+pkgver=v1.8
+pkgrel=1
+pkgdesc="SystemWorkbench for STM32"
+arch=('x86_64')
+url="http://www.openstm32.org/System+Workbench+for+STM32"
+license=('unknown')
+depends=('desktop-file-utils')
+source=(http://www.ac6-tools.com/downloads/SW4STM32/install_sw4stm32_linux_64bits-$pkgver.run
+ sw4stm32
+ sw4stm32.desktop)
+md5sums=('f4cf8d73b867cf7c7f261a8bfea3a8b2'
+ '2cb47631f9c17ae30890001eec765107'
+ 'fab1a998b1f24153827bfb4d9013240f')
+noextract=(install_sw4stm32_linux_64bits-$pkgver.run)
+
+
+package() {
+ mkdir -p $pkgdir/opt/sw4stm32
+
+ chmod +x install_sw4stm32_linux_64bits-$pkgver.run
+
+ # See https://izpack.atlassian.net/wiki/display/IZPACK/Unattended+Installations+Using+Properties
+ # for command-line instructions
+ yes | java -DINSTALL_PATH=$pkgdir/opt/sw4stm32 -d64 \
+ -jar install_sw4stm32_linux_64bits-$pkgver.run -options-system
+
+ # Extract icon
+ convert "${pkgdir}/opt/sw4stm32/logo_openstm32.ico" "${srcdir}/${pkgname}.png"
+
+ # Copy icon and desktop
+ install -Dm644 "${srcdir}/sw4stm32-12.png" "${pkgdir}/opt/sw4stm32/icon.png"
+ install -Dm644 "sw4stm32.desktop" "${pkgdir}/usr/local/share/applications/sw4stm32.desktop"
+
+ # Copy bash executable to path
+ install -Dm755 sw4stm32 $pkgdir/usr/local/bin/sw4stm32
+}
+
+post_install() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+
+
diff --git a/sw4stm32 b/sw4stm32
new file mode 100644
index 000000000000..d9ec1b01ff81
--- /dev/null
+++ b/sw4stm32
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/opt/sw4stm32/eclipse
diff --git a/sw4stm32.desktop b/sw4stm32.desktop
new file mode 100644
index 000000000000..b774c7f89d94
--- /dev/null
+++ b/sw4stm32.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=SW4STM32
+Comment=System Workbench for STM32
+Exec=sw4stm32
+Icon=/opt/sw4stm32/icon.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Applications;Development