summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-05-31 20:29:21 +0200
committerJakob Gahde2016-05-31 20:29:21 +0200
commitbd1e210aaa235fbc4ff49f27ace415058b712cb7 (patch)
treefb1ada5a3bcc2b2c58c57ab6c31cbde5cb6b9663
downloadaur-bd1e210aaa235fbc4ff49f27ace415058b712cb7.tar.gz
swac-record 0.4-1: Initial package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--fix-flac-libs.patch12
-rw-r--r--set-target-path.patch11
-rw-r--r--swac-record.desktop9
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9913a8a592b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue May 31 18:28:28 UTC 2016
+pkgbase = swac-record
+ pkgdesc = A program for systematically recording words or expressions
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://zmoo.fr/swac-tools/swac-record.php
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ depends = portaudio
+ source = http://zmoo.fr/download/swac-record-0.4.tar.gz
+ source = fix-flac-libs.patch
+ source = set-target-path.patch
+ source = swac-record.desktop
+ md5sums = dc128742664b65a97f49b00ed2c78da9
+ md5sums = 28ba6df7586ae7a80daa8240b0356a08
+ md5sums = 5904a3b1365a24c7cc5984bae324b962
+ md5sums = 8bdbf179e7f7b2861b358f01bb7ff76f
+
+pkgname = swac-record
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f4580df0dcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=swac-record
+pkgver=0.4
+pkgrel=1
+pkgdesc="A program for systematically recording words or expressions"
+arch=('i686' 'x86_64')
+url="http://zmoo.fr/swac-tools/swac-record.php"
+license=('GPL3')
+depends=('qt4' 'portaudio')
+source=("http://zmoo.fr/download/${pkgname}-${pkgver}.tar.gz"
+ "fix-flac-libs.patch"
+ "set-target-path.patch"
+ "swac-record.desktop")
+md5sums=('dc128742664b65a97f49b00ed2c78da9'
+ '28ba6df7586ae7a80daa8240b0356a08'
+ '5904a3b1365a24c7cc5984bae324b962'
+ '8bdbf179e7f7b2861b358f01bb7ff76f')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/fix-flac-libs.patch"
+ patch -Np1 < "${srcdir}/set-target-path.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make install INSTALL_ROOT=$pkgdir
+ install -Dm644 "${srcdir}/swac-record.desktop" "${pkgdir}/usr/share/applications/swac-record.desktop"
+}
diff --git a/fix-flac-libs.patch b/fix-flac-libs.patch
new file mode 100644
index 000000000000..e028bc6cfc75
--- /dev/null
+++ b/fix-flac-libs.patch
@@ -0,0 +1,12 @@
+diff -aur package.pristine/swac-record.pro package.new/swac-record.pro
+--- package.pristine/swac-record.pro 2016-05-31 19:53:24.499749450 +0200
++++ package.new/swac-record.pro 2016-05-31 19:53:36.092999589 +0200
+@@ -44,7 +44,7 @@
+ RESOURCES = swac-record.qrc
+
+ CONFIG += link_pkgconfig
+-PKGCONFIG = portaudio-2.0 flac++
++PKGCONFIG = portaudio-2.0 flac++ flac
+
+ target.path=/usr/local/bin/$$TARGET
+ INSTALLS += target
diff --git a/set-target-path.patch b/set-target-path.patch
new file mode 100644
index 000000000000..c735759c6593
--- /dev/null
+++ b/set-target-path.patch
@@ -0,0 +1,11 @@
+diff -aur package.pristine/swac-record.pro package.new/swac-record.pro
+--- package.pristine/swac-record.pro 2016-05-31 19:57:23.701366152 +0200
++++ package.new/swac-record.pro 2016-05-31 19:57:48.644520470 +0200
+@@ -46,6 +46,6 @@
+ CONFIG += link_pkgconfig
+ PKGCONFIG = portaudio-2.0 flac++ flac
+
+-target.path=/usr/local/bin/$$TARGET
++target.path=/usr/bin/$$TARGET
+ INSTALLS += target
+
diff --git a/swac-record.desktop b/swac-record.desktop
new file mode 100644
index 000000000000..e15b3937fe86
--- /dev/null
+++ b/swac-record.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=swac-record
+GenericName=Systematic Audio Recorder
+Comment=Systematically record words or expressions
+Icon=default
+Exec=/usr/bin/swac-record
+Categories=AudioVideo;Audio;Recorder;