summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgandalf32020-02-13 17:26:37 -0800
committergandalf32020-02-13 17:26:37 -0800
commitc13cc73e245403b7b1ac71814cde8bede77707b7 (patch)
tree0eafcc81201249ecafc3c2579a7efaaca19b7894
downloadaur-c13cc73e245403b7b1ac71814cde8bede77707b7.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--cwd.patch3
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b2f6716dc05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = swami
+ pkgdesc = A SoundFont editor
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://www.swamiproject.org
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = gtk2
+ depends = fftw
+ depends = audiofile
+ depends = fluidsynth
+ optdepends = libpng
+ source = https://github.com/swami/swami/archive/v2.2.0.tar.gz
+ source = cwd.patch
+ sha1sums = 218685dec42d2db2dffa77a28633096d29458950
+ sha1sums = c8f475348486f7664deb1d47afa90039d31529e8
+
+pkgname = swami
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..867489590fc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# gandalf3 <gandalf3@blendermonkey.com>
+
+pkgname=swami
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='A SoundFont editor'
+arch=('x86_64')
+url='http://www.swamiproject.org'
+license=('GPL2')
+depends=('gtk2' 'fftw' 'audiofile' 'fluidsynth')
+makedepends=('cmake')
+optdepends=('libpng')
+source=("https://github.com/swami/${pkgname}/archive/v${pkgver}.tar.gz" 'cwd.patch')
+sha1sums=('218685dec42d2db2dffa77a28633096d29458950'
+ 'c8f475348486f7664deb1d47afa90039d31529e8')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch src/swamigui/main.c < ../cwd.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cmake '-D CMAKE_INSTALL_PREFIX=/usr' .
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/cwd.patch b/cwd.patch
new file mode 100644
index 000000000000..6fe0bb9d1437
--- /dev/null
+++ b/cwd.patch
@@ -0,0 +1,3 @@
+52a53,54
+>
+> chdir("/usr");