summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuggy2024-04-14 16:57:41 +0900
committerhuggy2024-04-14 16:57:41 +0900
commitda484752783995d78129fb75cd59d744a7f9fc6e (patch)
tree20b3609fa0a0e46a9fd725473219d5d68f6b59e8
downloadaur-swan-updown.tar.gz
initial 0.3.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8b53de74bd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = swan-updown
+ pkgdesc = swan-updown helps create XFRM interfaces on demand
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/6-6-6/swan-updown
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/6-6-6/swan-updown/archive/refs/tags/v0.3.0.tar.gz
+ sha512sums = d01d5c88bdc30244cece300183aba2ad38c04a161fb9d45fdc6a59a53a71d74974a59e08e17fdceed58d641fe069969532d37ac5dd5fdbe591059adb33163cca
+
+pkgname = swan-updown \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f71e704c221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: 6-6-6 <33645950+6-6-6@users.noreply.github.com>
+# AUR Maintainer: huggy <arch@huggy.moe>
+# Contributor: Zhang Zongyu <zongyu@novazy.net>
+
+pkgname=swan-updown
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="swan-updown helps create XFRM interfaces on demand"
+arch=('x86_64' 'aarch64')
+url="https://github.com/6-6-6/swan-updown"
+license=('MIT')
+makedepends=('cargo')
+
+source=("https://github.com/6-6-6/swan-updown/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('d01d5c88bdc30244cece300183aba2ad38c04a161fb9d45fdc6a59a53a71d74974a59e08e17fdceed58d641fe069969532d37ac5dd5fdbe591059adb33163cca')
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/$pkgname "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file