summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Keith Darunday2022-09-29 05:02:47 +0800
committerJan Keith Darunday2022-09-29 05:04:18 +0800
commitd53530c60bb37f401257eabe3586f2149f2514cb (patch)
tree2233823dc906055f7cf144a5532fc1ec9766a974
downloadaur-d53530c60bb37f401257eabe3586f2149f2514cb.tar.gz
Add gitignore and initial PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD37
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ece233f4b00c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = swarm-desktop-bin
+ pkgdesc = Swarm client implemented in Go, basic building block for Swarm Network
+ pkgver = 0.16.0
+ pkgrel = 1
+ url = https://github.com/ethersphere/swarm-desktop
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ depends = bash
+ provides = swarm-desktop
+ conflicts = swarm-desktop
+ source = LICENSE
+ sha256sums = 4be8d688c385633c38b039843922abaf78eef2a3a762add25ade4dcb13de6cd3
+ source_x86_64 = swarm-desktop-bin-0.16.0-x86_64.deb::https://github.com/ethersphere/swarm-desktop/releases/download/v0.16.0/swarm-desktop_0.16.0_amd64.deb
+ sha256sums_x86_64 = 8172786083faab2c04286be5c81a6012dc6274a7da0e1514e0b00158116827a0
+ source_aarch64 = swarm-desktop-bin-0.16.0-aarch64.deb::https://github.com/ethersphere/swarm-desktop/releases/download/v0.16.0/swarm-desktop_0.16.0_arm64.deb
+ sha256sums_aarch64 = 1c687553f66d72f579bacd863930483432923c508bb7127e3a546855876b8dc2
+
+pkgname = swarm-desktop-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1b7e86c55ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.*
+*.pkg.tar
+*.deb
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4dc6dd1eee43
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2022, The Swarm Authors
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b681adcf8c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jan Keith Darunday <jkcdarunday+aur.archlinux.org@gmail.com>
+
+pkgname=swarm-desktop-bin
+pkgver=0.16.0
+pkgrel=1
+pkgdesc='Swarm client implemented in Go, basic building block for Swarm Network'
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+url='https://github.com/ethersphere/swarm-desktop'
+license=('BSD')
+depends=('bash')
+provides=('swarm-desktop')
+conflicts=('swarm-desktop')
+source=('LICENSE')
+source_x86_64=("$pkgname-$pkgver-x86_64.deb::$url/releases/download/v$pkgver/swarm-desktop_${pkgver}_amd64.deb")
+source_aarch64=("$pkgname-$pkgver-aarch64.deb::$url/releases/download/v$pkgver/swarm-desktop_${pkgver}_arm64.deb")
+sha256sums=('4be8d688c385633c38b039843922abaf78eef2a3a762add25ade4dcb13de6cd3')
+sha256sums_x86_64=('8172786083faab2c04286be5c81a6012dc6274a7da0e1514e0b00158116827a0')
+sha256sums_aarch64=('1c687553f66d72f579bacd863930483432923c508bb7127e3a546855876b8dc2')
+
+prepare() {
+ bsdtar -xf data.tar.xz
+}
+
+package() {
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 usr/share/applications/swarm-desktop.desktop -t "$pkgdir/usr/share/applications/"
+ install -Dm644 usr/share/doc/swarm-desktop/copyright -t "$pkgdir/usr/share/doc/swarm-desktop/"
+ install -Dm644 usr/share/lintian/overrides/swarm-desktop -t "$pkgdir/usr/share/lintian/overrides/"
+ install -Dm644 usr/share/pixmaps/swarm-desktop.png -t "$pkgdir/usr/share/pixmaps/"
+
+ install -dm755 "$pkgdir/opt"
+ cp -r --no-preserve=ownership usr/lib/swarm-desktop "$pkgdir/opt/swarm-desktop"
+
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -s /opt/swarm-desktop/swarm-desktop "$pkgdir/usr/bin/swarm-desktop"
+}
+