summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsplith2016-03-27 19:19:18 +0100
committersplith2016-03-27 19:19:18 +0100
commita505dbf686ab0876100ed6f66de9bd583d14e3e7 (patch)
treea9075213efdf4ae7677a93864640608baea182e3
downloadaur-a505dbf686ab0876100ed6f66de9bd583d14e3e7.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--swars.install3
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dde74adfb21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = swars
+ pkgdesc = Syndicate Wars, a classic 1996 strategy game, with SDL patches to make it playable natively on Linux. Requires the Syndicate Wars CD to copy data files from before first run.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://swars.vexillium.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ depends = lib32-sdl
+ depends = lib32-libvorbis
+ depends = lib32-libpng
+ depends = lib32-zlib
+ depends = lib32-openal
+ depends = lib32-cdparanoia
+ source = http://swars.vexillium.org/files/swars-0.3.tar.bz2
+ sha256sums = 01f44e5b792d41b138d361d04810a875cfa5f897c642a2b13d0dde633fabdacb
+
+pkgname = swars
+ install = swars.install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07e60358c369
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Splith <spam at helper3000 net>
+
+pkgname=swars
+pkgver=0.3
+pkgrel=1
+pkgdesc="Syndicate Wars, a classic 1996 strategy game, with SDL patches to make it playable natively on Linux. Requires the Syndicate Wars CD to copy data files from before first run."
+url="http://swars.vexillium.org/"
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=( 'lib32-sdl' 'lib32-libvorbis' 'lib32-libpng' 'lib32-zlib' 'lib32-openal' 'lib32-cdparanoia' )
+makedepends=('python2')
+source=("http://swars.vexillium.org/files/$pkgname-$pkgver.tar.bz2")
+sha256sums=('01f44e5b792d41b138d361d04810a875cfa5f897c642a2b13d0dde633fabdacb')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ ac_cv_prog_PYTHON=python2 ./configure --build=i686-pc-linux-gnu "CFLAGS=-m32" "CXXFLAGS=-m32" "LDFLAGS=-m32" --prefix=/usr --libdir=/usr/lib32
+ else
+ ac_cv_prog_PYTHON=python2 ./configure --prefix=/usr
+ fi
+
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ make
+}
+
+package () {
+ install=swars.install
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ mkdir "${pkgdir}/usr/share/swars"
+ install -Dm755 util/install "${pkgdir}/usr/share/swars/install"
+}
+
diff --git a/swars.install b/swars.install
new file mode 100644
index 000000000000..7ccb5160f057
--- /dev/null
+++ b/swars.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Syndicate Wars will not work until data has been copied/converted from an original CD. Firstly insert your Syndicate Wars CD or mount if you have an image file, then open in a terminal at /usr/share/swars/ and run the install script: ./install -f <mount point of CD/image> -t /usr/share/swars after this process is finished, you can run Syndicate Wars by using swars"
+}