summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-05-22 01:02:43 +0300
committerIgor Dyatlov2022-05-22 01:02:43 +0300
commitd01390f386c0d8a66b2f0e033cb480f6f6c7a1c2 (patch)
treea052efab484451308d1babce19f4435363622aae
downloadaur-d01390f386c0d8a66b2f0e033cb480f6f6c7a1c2.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3175fc332b7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = swatch-git
+ pkgdesc = Color palette manager
+ pkgver = 1.0.r1.gfedb54b
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GabMus/swatch
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = gobject-introspection
+ makedepends = blueprint-compiler
+ depends = glib2
+ depends = libadwaita
+ provides = swatch
+ conflicts = swatch
+ source = git+https://gitlab.gnome.org/GabMus/swatch.git
+ b2sums = SKIP
+
+pkgname = swatch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdb87d5e3970
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=swatch-git
+pkgver=1.0.r1.gfedb54b
+pkgrel=1
+pkgdesc="Color palette manager"
+arch=('any')
+url="https://gitlab.gnome.org/GabMus/swatch"
+license=('GPL3')
+depends=('glib2' 'libadwaita')
+makedepends=('git' 'meson' 'gobject-introspection' 'blueprint-compiler')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+#check() {
+# meson test -C build
+#}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}