summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2023-12-04 01:48:20 +0100
committerFerdinand Bachmann2023-12-04 01:48:20 +0100
commitab0339fe0ea2ef01de3cc2c7d71f22ded9a44a89 (patch)
tree442558454989471b8136f1d88f0cde7d293c6fb5
parent10202d649b3661fb3faae57ec9c15a0459c74ee6 (diff)
downloadaur-ab0339fe0ea2ef01de3cc2c7d71f22ded9a44a89.tar.gz
merge upstream changes
-rw-r--r--.SRCINFO45
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD122
-rw-r--r--sway-git.install23
-rw-r--r--sway.install7
5 files changed, 104 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49801710510b..dfe698bbce76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,46 +1,49 @@
pkgbase = sway-asan-git
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager (with address sanitizer)
- pkgver = r7040.bd7466e1
+ pkgver = r7218.f12023b1
pkgrel = 1
url = https://swaywm.org
- install = sway.install
- arch = i686
+ install = sway-git.install
arch = x86_64
license = MIT
makedepends = git
+ makedepends = libcap
makedepends = meson
makedepends = scdoc
makedepends = wayland-protocols
depends = cairo
depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
depends = json-c
+ depends = libevdev
+ depends = libinput
+ depends = libxcb
+ depends = libxkbcommon
depends = pango
- depends = polkit
depends = pcre2
- depends = swaybg-git
- depends = ttf-font
+ depends = pixman
+ depends = systemd-libs
+ depends = wayland
depends = wlroots-git
- depends = xorg-server-xwayland
- optdepends = alacritty: Terminal emulator used by the default config
- optdepends = dmenu: Application launcher
- optdepends = grim: Screenshot utility
- optdepends = i3status: Status line
- optdepends = mako: Lightweight notification daemon
- optdepends = slurp: Select a region
+ depends = xcb-util-wm
+ optdepends = wmenu: Application launcher used in default configuration
+ optdepends = foot: Terminal emulator used in default configuration
+ optdepends = polkit: System privilege control. Required if not using seatd service
+ optdepends = swaybg: Wallpaper tool for sway
optdepends = swayidle: Idle management daemon
optdepends = swaylock: Screen locker
- optdepends = wallutils: Timed wallpapers
- optdepends = waybar: Highly customizable bar
+ optdepends = xorg-xwayland: X11 support
provides = sway
- provides = sway-git=r7040.bd7466e1
+ provides = sway-git=r7218.f12023b1
conflicts = sway
- options = debug
+ conflicts = sway-git
backup = etc/sway/config
- source = sway::git+https://github.com/swaywm/sway.git
+ source = sway-asan-git::git+https://github.com/swaywm/sway.git
source = 50-systemd-user.conf
source = 0001-asan-options.patch
- sha512sums = SKIP
- sha512sums = c2b7d808f4231f318e03789015624fd4cf32b81434b15406570b4e144c0defc54e216d881447e6fd9fc18d7da608cccb61c32e0e1fab2f1fe2750acf812d3137
- sha512sums = 9e24967087b7e062b77e735260c4b30cd8dcf77c03358e658ec854b8387d66310c99d93fde11ec00de45073e949a1df0c4c721d765e62944ae227913b667be6e
+ b2sums = SKIP
+ b2sums = 95e0862807c3b5bb490b88c46e6d2d4deaa8ba0d18be0c169f3d57606acbfa124cb712b48b22ab6f12f247ac5b8d5d3cf4db85f7b04420845c0e3ed742edf917
+ b2sums = 30efac9b5d06babb8ee9b35a25887b403d9e0e0a81078841d3837e075ce84a3a8aa93cbdd156db092c333b9b98e4ce3fd1ab40078ac1a90e243f1e24b9ebf5be
pkgname = sway-asan-git
diff --git a/.gitignore b/.gitignore
index 5871abd07070..1709d54353d0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-sway/
-sway-asan/
+sway-asan-git/
src/
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index e83161cebefb..fe7da9c85455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,90 +1,80 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: GreyXor <greyxor@protonmail.com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
+
pkgname=sway-asan-git
-_pkgname=sway
-pkgver=r7040.bd7466e1
+pkgver=r7218.f12023b1
pkgrel=1
-license=("MIT")
+arch=('x86_64')
pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager (with address sanitizer)"
-makedepends=(
- "git"
- "meson"
- "scdoc"
- "wayland-protocols"
-)
+url='https://swaywm.org'
+license=('MIT')
depends=(
- "cairo"
- "gdk-pixbuf2"
- "json-c"
- "pango"
- "polkit"
- "pcre2"
- "swaybg-git"
- "ttf-font"
- "wlroots-git"
- "xorg-server-xwayland"
+ "cairo"
+ "gdk-pixbuf2"
+ "glib2"
+ "glibc"
+ "json-c"
+ "libevdev"
+ "libinput"
+ "libxcb"
+ "libxkbcommon"
+ "pango"
+ "pcre2"
+ "pixman"
+ "systemd-libs"
+ "wayland"
+ "wlroots-git"
+ "xcb-util-wm"
)
-optdepends=(
- "alacritty: Terminal emulator used by the default config"
- "dmenu: Application launcher"
- "grim: Screenshot utility"
- "i3status: Status line"
- "mako: Lightweight notification daemon"
- "slurp: Select a region"
- "swayidle: Idle management daemon"
- "swaylock: Screen locker"
- "wallutils: Timed wallpapers"
- "waybar: Highly customizable bar"
+makedepends=(
+ "git"
+ "libcap"
+ "meson"
+ "scdoc"
+ "wayland-protocols"
)
-backup=(etc/sway/config)
-arch=("i686" "x86_64")
-url="https://swaywm.org"
-source=(
- "${pkgname%-asan-*}::git+https://github.com/swaywm/sway.git"
- 50-systemd-user.conf
- 0001-asan-options.patch
+optdepends=(
+ 'wmenu: Application launcher used in default configuration'
+ 'foot: Terminal emulator used in default configuration'
+ 'polkit: System privilege control. Required if not using seatd service'
+ 'swaybg: Wallpaper tool for sway'
+ 'swayidle: Idle management daemon'
+ 'swaylock: Screen locker'
+ 'xorg-xwayland: X11 support'
)
-sha512sums=('SKIP'
- 'c2b7d808f4231f318e03789015624fd4cf32b81434b15406570b4e144c0defc54e216d881447e6fd9fc18d7da608cccb61c32e0e1fab2f1fe2750acf812d3137'
- '9e24967087b7e062b77e735260c4b30cd8dcf77c03358e658ec854b8387d66310c99d93fde11ec00de45073e949a1df0c4c721d765e62944ae227913b667be6e')
-provides=("sway" "sway-git=${pkgver}")
-conflicts=("sway")
-options=(debug)
-install=sway.install
+install=sway-git.install
+provides=("${pkgname%-asan-git}" "${pkgname/-asan/}=${pkgver}")
+conflicts=("${pkgname%-asan-git}" "${pkgname/-asan/}")
+backup=("etc/sway/config")
+source=("${pkgname}::git+https://github.com/swaywm/sway.git"
+ "50-systemd-user.conf"
+ "0001-asan-options.patch")
+b2sums=('SKIP'
+ '95e0862807c3b5bb490b88c46e6d2d4deaa8ba0d18be0c169f3d57606acbfa124cb712b48b22ab6f12f247ac5b8d5d3cf4db85f7b04420845c0e3ed742edf917'
+ '30efac9b5d06babb8ee9b35a25887b403d9e0e0a81078841d3837e075ce84a3a8aa93cbdd156db092c333b9b98e4ce3fd1ab40078ac1a90e243f1e24b9ebf5be')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # Calculate the version dynamically using git information
+ printf "r%s.%s" "$(git -C "$srcdir/${pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${pkgname}" rev-parse --short HEAD)"
}
prepare() {
- cd "$_pkgname"
- for f in "$srcdir"/*.patch; do
+ cd "$pkgname"
+ for f in "$srcdir"/*.patch; do
patch -p1 < "$f"
done
}
build() {
- CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
- -Dsd-bus-provider=libsystemd \
- -Dwerror=false \
- "$_pkgname" build
+ CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson "${pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
+
meson compile -C build
}
package() {
- install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
-
- DESTDIR="$pkgdir" meson install -C build
-
- cd "$_pkgname"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
- install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
- done
-}
+ meson install -C build --destdir "$pkgdir"
-post_upgrade() {
- echo "Make sure to upgrade wlroots-git and sway-git together."
- echo "Upgrading one but not the other is unsupported."
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+ install -Dm644 "${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/sway-git.install b/sway-git.install
new file mode 100644
index 000000000000..0a951fe81976
--- /dev/null
+++ b/sway-git.install
@@ -0,0 +1,23 @@
+upgrade_wlroots_message() {
+ cat <<END
+
+Please make sure your wlroots-git is up-to-date before compiling sway-git.
+
+END
+}
+
+pre_install() {
+ upgrade_wlroots_message
+}
+
+pre_upgrade() {
+ upgrade_wlroots_message
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ setcap cap_sys_nice+eip usr/bin/sway
+}
diff --git a/sway.install b/sway.install
deleted file mode 100644
index 824ed4c04a9b..000000000000
--- a/sway.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- post_upgrade
-}
-
-post_upgrade() {
- setcap cap_sys_nice+eip usr/bin/sway
-}