summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheAvidDev2020-11-05 18:17:47 -0500
committerTheAvidDev2020-11-05 18:17:47 -0500
commit2f867d08fa7ed95121ecc33beca4e2d42c76b9cb (patch)
treeef613a7f4cee25e3bfbeab60abebf93dbdae2a95
downloadaur-2f867d08fa7ed95121ecc33beca4e2d42c76b9cb.tar.gz
Initial commit
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD72
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..695e2d45a579
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = sway-borders-git
+ pkgdesc = Fork of Sway with some additional (mostly graphical) features
+ pkgver = r6547.a854f050
+ pkgrel = 1
+ url = https://github.com/TheAvidDev/sway-borders
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = json-c
+ depends = pango
+ depends = polkit
+ depends = pcre
+ depends = swaybg-git
+ depends = ttf-font
+ depends = wlroots-git
+ depends = xorg-server-xwayland
+ optdepends = alacritty: Terminal emulator used by the default config
+ optdepends = dmenu: Application launcher
+ optdepends = grim: Screenshot utility
+ optdepends = i3status: Status line
+ optdepends = mako: Lightweight notification daemon
+ optdepends = slurp: Select a region
+ optdepends = swayidle-git: Idle management daemon for Sway
+ optdepends = swaylock-git: Screen locker for Sway
+ optdepends = wallutils: Timed wallpapers
+ optdepends = waybar: Highly customizable bar
+ provides = sway
+ conflicts = sway
+ options = debug
+ backup = etc/sway/config
+ source = sway-borders::git+https://github.com/TheAvidDev/sway-borders.git
+ sha512sums = SKIP
+
+pkgname = sway-borders-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38b13282be74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Steven Guikal <aur-void@theavid.dev>
+
+pkgname=sway-borders-git
+_pkgname=sway-borders
+pkgver=r6547.a854f050
+pkgrel=1
+license=("MIT")
+pkgdesc="Fork of Sway with some additional (mostly graphical) features"
+makedepends=(
+ "git"
+ "meson"
+ "ninja"
+ "scdoc"
+ "wayland-protocols"
+)
+depends=(
+ "cairo"
+ "gdk-pixbuf2"
+ "json-c"
+ "pango"
+ "polkit"
+ "pcre"
+ "swaybg-git"
+ "ttf-font"
+ "wlroots-git"
+ "xorg-server-xwayland"
+)
+optdepends=(
+ "alacritty: Terminal emulator used by the default config"
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "i3status: Status line"
+ "mako: Lightweight notification daemon"
+ "slurp: Select a region"
+ "swayidle-git: Idle management daemon for Sway"
+ "swaylock-git: Screen locker for Sway"
+ "wallutils: Timed wallpapers"
+ "waybar: Highly customizable bar"
+)
+backup=(etc/sway/config)
+arch=("i686" "x86_64")
+url="https://github.com/TheAvidDev/sway-borders"
+source=("${pkgname%-*}::git+https://github.com/TheAvidDev/sway-borders.git")
+sha512sums=("SKIP")
+provides=("sway")
+conflicts=("sway")
+options=(debug)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+}
+
+build() {
+ cd "$_pkgname"
+ meson \
+ -Dwerror=false \
+ --prefix /usr \
+ "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}