summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyXor2023-08-26 10:54:53 +0200
committerGreyXor2023-08-26 10:54:53 +0200
commit61baa6bfb6eb0e8196b4f21fef817f7796d2cc6a (patch)
tree52bda5372dafb4307b47ab645ed9b243f6c10ca0
parentc50369abf7f9dcb6abc20a3a882a107db386c9b8 (diff)
downloadaur-61baa6bfb6eb0e8196b4f21fef817f7796d2cc6a.tar.gz
fix: provides and conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c274a4697893..556cfc49c9b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sway-git
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager
pkgver = r7177.4a221057
- pkgrel = 2
+ pkgrel = 1
url = https://swaywm.org/
install = sway-git.install
arch = x86_64
@@ -34,8 +34,8 @@ pkgbase = sway-git
optdepends = swayidle-git: Idle management daemon
optdepends = swaylock-git: Screen locker
optdepends = xorg-xwayland: X11 support
- provides = sway-git
- conflicts = sway-git
+ provides = sway
+ conflicts = sway
options = debug
backup = etc/sway/config
source = sway-git::git+https://github.com/swaywm/sway.git
diff --git a/PKGBUILD b/PKGBUILD
index 2e9ccd63e1ea..b52db66e4475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=sway-git
-_pkgname=${pkgname%*}
+_pkgname=${pkgname%-git}
pkgver=r7177.4a221057
-pkgrel=2
+pkgrel=1
arch=('x86_64')
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager'
url='https://swaywm.org/'
@@ -48,7 +48,7 @@ install=sway-git.install
provides=("${_pkgname}")
conflicts=("${_pkgname}")
backup=("etc/sway/config")
-source=("${_pkgname}::git+https://github.com/swaywm/sway.git"
+source=("${pkgname}::git+https://github.com/swaywm/sway.git"
"50-systemd-user.conf")
b2sums=('SKIP'
'95e0862807c3b5bb490b88c46e6d2d4deaa8ba0d18be0c169f3d57606acbfa124cb712b48b22ab6f12f247ac5b8d5d3cf4db85f7b04420845c0e3ed742edf917')
@@ -56,11 +56,11 @@ options=(debug)
pkgver() {
# Calculate the version dynamically using git information
- printf "r%s.%s" "$(git -C "$srcdir/${_pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${_pkgname}" rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git -C "$srcdir/${pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${pkgname}" rev-parse --short HEAD)"
}
build() {
- arch-meson "${_pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
+ arch-meson "${pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
meson compile -C build
}
@@ -73,5 +73,5 @@ package() {
meson install -C build --destdir "$pkgdir"
install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
- install -Dm644 "${_pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}