summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2016-02-18 07:56:32 -0500
committerDrew DeVault2016-02-18 07:56:32 -0500
commita5361b9f64763a879818503e46be0b1c86ac9a0e (patch)
tree491a78bc2f5c28081fab39b8d9d767fef2175371
parentd6e021e13408a5fa65e11b7fe0411848d0e008df (diff)
downloadaur-a5361b9f64763a879818503e46be0b1c86ac9a0e.tar.gz
Add debug/!strip and set cmake build to Upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d412143a11e5..26fc8903b17d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 27 16:08:19 UTC 2015
+# Thu Feb 18 12:56:28 UTC 2016
pkgbase = sway-git
pkgdesc = i3 compatible window manager for Wayland
- pkgver = r1138.82aca85
+ pkgver = r1302.016a774
pkgrel = 1
url = https://github.com/SirCmpwn/sway
arch = i686
@@ -24,6 +24,8 @@ pkgbase = sway-git
optdepends = imagemagick: For taking screenshots.
optdepends = ffmpeg: For recording screencasts.
optdepends = i3status: To display system information with a bar.
+ options = debug
+ options = !strip
source = sway::git+https://github.com/SirCmpwn/sway.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 85f31e7e6689..cdddb7fb1f75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=sway-git
_pkgname=sway
-pkgver=r1138.82aca85
+pkgver=r1302.016a774
pkgrel=1
license=('MIT')
pkgdesc='i3 compatible window manager for Wayland'
@@ -23,6 +23,7 @@ arch=("i686" "x86_64")
url='https://github.com/SirCmpwn/sway'
source=("${pkgname%-*}::git+https://github.com/SirCmpwn/sway.git")
sha1sums=('SKIP')
+options=('debug' '!strip')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -32,7 +33,7 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_INSTALL_PREFIX=/usr
+ cmake . -DCMAKE_BUILD_TYPE=Upstream -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_INSTALL_PREFIX=/usr
make
}