summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2019-06-11 11:23:40 -0600
committerDrew DeVault2019-06-12 10:21:02 -0400
commit3d34dd0d18b01dd8d5e067d19849a4c9549c7818 (patch)
tree0ba864a617d8da91c314761354612fe9ca188fcf
parent4037cf2d5c7393d75bd82c797ebea5787e8b3720 (diff)
downloadaur-3d34dd0d18b01dd8d5e067d19849a4c9549c7818.tar.gz
Use release builds, and run meson in build()
meson/configure should be run in build() and not prepare(), as CFLAGS/CXXFLAGS/etc. from makepkg.conf are not set in prepare(). This patch moves the meson run from build() -> prepare() so that the flags from makepkg are included in the environment.
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa24b756b43b..a4665bb6b779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=sway-git
_pkgname=sway
-pkgver=r5893.e6fbb3c6
+pkgver=r5942.3f77591b
pkgrel=1
license=("MIT")
pkgdesc="i3-compatible Wayland compositor"
-makedepends=("meson" "git" "scdoc" "wayland-protocols")
+makedepends=("meson" "git" "scdoc" "wayland-protocols" "ninja")
depends=(
"json-c" "pcre" "wlroots-git" "cairo" "pango" "gdk-pixbuf2" "pam"
"xorg-server-xwayland" "swaybg-git"
@@ -20,7 +20,7 @@ optdepends=(
arch=("i686" "x86_64")
url="https://swaywm.org"
source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git")
-sha1sums=("SKIP")
+sha512sums=('SKIP')
provides=("sway")
conflicts=("sway")
options=(debug !strip)
@@ -32,11 +32,14 @@ pkgver() {
prepare() {
cd "$_pkgname"
- meson -Dwerror=false --prefix /usr "$srcdir/build"
}
build() {
cd "$_pkgname"
+ meson \
+ -Dwerror=false \
+ --prefix /usr \
+ "$srcdir/build"
ninja -C "$srcdir/build"
}