summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitaliy Berdinskikh2019-03-23 21:27:08 +0200
committerVitaliy Berdinskikh2019-03-23 21:27:08 +0200
commit4ba3a8ee012b3f4580a3a30ef216090dca5366af (patch)
treea65fb927773efe540b5f02dcc6f5246a1e3c7182
downloadaur-4ba3a8ee012b3f4580a3a30ef216090dca5366af.tar.gz
v1.0.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--sway-keyboard-layout.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87a6f93159b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sway-keyboard-layout
+ pkgdesc = Put your screenshots to XDG_PICTURES_DIR folder
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/racy/sway-keyboard-layout
+ install = sway-keyboard-layout.install
+ arch = i686
+ arch = x86_64
+ license = Apache2
+ depends = sway
+ depends = i3status
+ depends = xkblayout
+ source = https://gitlab.com/racy/sway-keyboard-layout/-/archive/1.0.0/sway-keyboard-layout-1.0.0.tar.bz2
+ sha256sums = f29bddd169f4103750bc74d90f98f5520b07c7352c657440afe5ace91c72e3dc
+
+pkgname = sway-keyboard-layout
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b88dab82f69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Vitaliy Berdinskikh <ur6lad at tuta dot io>
+pkgname=sway-keyboard-layout
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Put your screenshots to XDG_PICTURES_DIR folder'
+arch=('i686' 'x86_64')
+url='https://gitlab.com/racy/sway-keyboard-layout'
+license=('Apache2')
+depends=('sway' 'i3status' 'xkblayout')
+install=sway-keyboard-layout.install
+source=(https://gitlab.com/racy/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
+sha256sums=('f29bddd169f4103750bc74d90f98f5520b07c7352c657440afe5ace91c72e3dc')
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ install -d "$pkgdir"/usr/bin
+ install -m 755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/sway-keyboard-layout.install b/sway-keyboard-layout.install
new file mode 100644
index 000000000000..1585e8446724
--- /dev/null
+++ b/sway-keyboard-layout.install
@@ -0,0 +1,15 @@
+post_install() {
+ cat <<EOT
+Replace status command in your Sway configuration:
+
+ status_command i3status | sway-keyboard-layout i3status
+EOT
+}
+
+pre_remove() {
+ cat <<EOT
+Restore status command in your Sway configuration:
+
+ status_command i3status
+EOT
+} \ No newline at end of file