summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoremilylime2024-06-23 22:01:53 +0300
committeremilylime2024-06-23 22:01:53 +0300
commitaecd7a53e93e14adcf41d3d3abb8e446d5aac122 (patch)
tree80093268f1d8b0cbc4631f0a73e1e804544c6e3a
parent664e2f18136cb4db4b7f3cb03efd65cb93ae9f79 (diff)
downloadaur-aecd7a53e93e14adcf41d3d3abb8e446d5aac122.tar.gz
Update for sway-scratchpad
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03180a0ba604..7f2072f3df41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
-pkgbase = i3-scratchpad-git
- pkgdesc = The Swiss Army Knife of floating i3 windows
- pkgver = 1.1
+pkgbase = sway-scratchpad-git
+ pkgdesc = The Swiss Army Knife of floating i3/Sway windows
+ pkgver = 2.0
pkgrel = 1
+ url = https://github.com/emilyyyylime/sway-scratchpad
arch = any
license = Unlicense
- depends = i3-wm
- depends = wmctrl
+ makedepends = git
depends = bash
- depends = xdotool
- optdepends = rxvt-unicode: for terminal programs support
- source = git+https://gitlab.com/aquator/i3-scratchpad.git
+ depends = jq
+ depends = coreutils
+ provides = i3-scratchpad-git
+ source = git+https://github.com/emilyyyylime/sway-scratchpad.git
md5sums = SKIP
-pkgname = i3-scratchpad-git
-
+pkgname = sway-scratchpad-git
diff --git a/PKGBUILD b/PKGBUILD
index 68c9509875b5..30cb3e98bbbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,18 @@
-# Maintainer: Thomas Simatic <thomas.sim@mailo.com>
-pkgname="i3-scratchpad-git"
-pkgver=1.1
+# Maintainer: emilylime <emilyyyylime+aur@gmail.com>
+# Contributor: Thomas Simatic <thomas.sim@mailo.com>
+pkgname="sway-scratchpad-git"
+pkgver=2.0
pkgrel=1
-pkgdesc="The Swiss Army Knife of floating i3 windows"
+pkgdesc="The Swiss Army Knife of floating i3/Sway windows"
arch=(any)
+url="https://github.com/emilyyyylime/sway-scratchpad"
license=('Unlicense')
-depends=(i3-wm wmctrl bash xdotool)
-optdepends=('rxvt-unicode: for terminal programs support')
+depends=(bash jq coreutils)
+makedepends=(git)
+optdepends=()
+provides=(i3-scratchpad-git)
-source=("git+https://gitlab.com/aquator/i3-scratchpad.git")
+source=("git+https://github.com/emilyyyylime/sway-scratchpad.git")
md5sums=(SKIP)
pkgver() {
@@ -18,5 +22,5 @@ pkgver() {
package() {
cd ${pkgname%-git}
- install -Dm 755 i3-scratchpad -t "$pkgdir"/usr/bin
+ install -Dm 755 ${pkgname%-git} -t "$pkgdir"/usr/bin
}