summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-30 01:34:32 -0500
committerVincent Grande2021-01-30 01:34:32 -0500
commit31ec034bdeed30741c32fe8f6c05f2d59b48e8ff (patch)
tree705aa340067034c0bf0edcd8bc5f2402491cf526
downloadaur-31ec034bdeed30741c32fe8f6c05f2d59b48e8ff.tar.gz
initial upload
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD80
-rw-r--r--sway-strace-git.install3
3 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33b0fbf9a0ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = sway-nosystemd-minimal-git
+ pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager
+ pkgver = r6506.1be66c98
+ pkgrel = 1
+ url = https://swaywm.org
+ install = sway-strace-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = wayland-protocols
+ makedepends = wlroots-strace-git
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = json-c
+ depends = pango
+ depends = pcre
+ depends = swaybg-git
+ depends = ttf-font
+ depends = wlroots-strace-git
+ depends = xorg-server-xwayland
+ optdepends = alacritty: Terminal emulator used by the default config
+ optdepends = dmenu: Application launcher
+ optdepends = grim: Screenshot utility
+ optdepends = i3status: Status line
+ optdepends = mako: Lightweight notification daemon
+ optdepends = polkit: polkit support
+ optdepends = slurp: Select a region
+ optdepends = swayidle: Idle management daemon
+ optdepends = swaylock: Screen locker
+ optdepends = wallutils: Timed wallpapers
+ optdepends = waybar: Highly customizable bar
+ provides = sway
+ conflicts = sway
+ backup = etc/sway/config
+ source = sway-nosystemd-minimal::git+https://github.com/swaywm/sway.git
+ sha512sums = SKIP
+
+pkgname = sway-nosystemd-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2349371d16cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
+# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
+pkgname=sway-nosystemd-minimal-git
+_pkgname=sway-nosystemd-minimal
+pkgver=r6506.1be66c98
+pkgrel=1
+license=("MIT")
+pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager"
+makedepends=(
+ "git"
+ "meson"
+ "ninja"
+# "scdoc"
+ "wayland-protocols"
+ "wlroots-strace-git"
+)
+depends=(
+ "cairo"
+ "gdk-pixbuf2"
+ "json-c"
+ "pango"
+ "pcre"
+ "swaybg-git"
+ "ttf-font"
+ "wlroots-strace-git"
+ "xorg-server-xwayland"
+)
+optdepends=(
+ "alacritty: Terminal emulator used by the default config"
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "i3status: Status line"
+ "mako: Lightweight notification daemon"
+ "polkit: polkit support"
+ "slurp: Select a region"
+ "swayidle: Idle management daemon"
+ "swaylock: Screen locker"
+ "wallutils: Timed wallpapers"
+ "waybar: Highly customizable bar"
+)
+backup=(etc/sway/config)
+arch=("i686" "x86_64")
+url="https://swaywm.org"
+source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git")
+sha512sums=("SKIP")
+provides=("sway")
+conflicts=("sway")
+#options=(debug)
+install=sway-strace-git.install
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ meson \
+ -Dwerror=false \
+ -Dtray=enabled \
+ -Dgdk-pixbuf=enabled \
+ -Dman-pages=disabled \
+ --prefix /usr \
+ -Db_sanitize=address,undefined \
+ "$srcdir/build"
+ ninja $NINJAFLAGS -C "$srcdir/build"
+}
+
+package() {
+
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja $NINJAFLAGS -C "$srcdir/build" install
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
+ install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
+ done
+}
diff --git a/sway-strace-git.install b/sway-strace-git.install
new file mode 100644
index 000000000000..2a7a1b5ef3d5
--- /dev/null
+++ b/sway-strace-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "You must launch sway like this to enable strace: ASAN_OPTIONS=abort_on_error=1:disable_coredump=0:unmap_shadow_on_exit=1 sway"
+}