summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Janzic2021-06-03 21:34:32 +0200
committerJosip Janzic2021-06-03 21:34:32 +0200
commitb56c4394ceee10649ea9a5d31631652c871f9dbb (patch)
treeb8ac374b80c3a48cbacad6441d67ae3bff98c501
parente492d504ff943da1d4b08f8ac88264600b9a84e6 (diff)
downloadaur-b56c4394ceee10649ea9a5d31631652c871f9dbb.tar.gz
Use git patch instead of branch for source
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a92c5fc5a13..3e43a2dcb42b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sway-titlebar-positioning-git
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager patched with config option to have titlebars on the bottom
- pkgver = r6651.2bba3c7d
+ pkgver = r6704.b9971472
pkgrel = 1
url = https://swaywm.org
arch = i686
@@ -34,10 +34,11 @@ pkgbase = sway-titlebar-positioning-git
conflicts = sway
options = debug
backup = etc/sway/config
- source = sway-titlebar-positioning::git+https://github.com/janza/sway.git#titlebar-position
+ source = sway-titlebar-positioning::git+https://github.com/swaywm/sway.git
+ source = titlebar_position.diff::https://github.com/swaywm/sway/compare/master...janza:titlebar-position.diff
source = 50-systemd-user.conf
sha512sums = SKIP
+ sha512sums = 73ec0b3f4599574bd4b17858957868ea0dfc3a6d0bb34efcf8378a38de5fa947426ee1447b1c2f7bc2ecb67c9ce22d922641815aeb56d641593293203684c792
sha512sums = 57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e
pkgname = sway-titlebar-positioning-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f4eab9e21a59..8bb629f11d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Drew DeVault <sir@cmpwn.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=sway-titlebar-positioning-git
-_pkgname=sway
-pkgver=r6651.2bba3c7d
+_pkgname=sway-titlebar-positioning
+pkgver=r6704.b9971472
pkgrel=1
license=("MIT")
pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager patched with config option to have titlebars on the bottom"
@@ -40,9 +40,11 @@ optdepends=(
backup=(etc/sway/config)
arch=("i686" "x86_64")
url="https://swaywm.org"
-source=("${pkgname%-*}::git+https://github.com/janza/sway.git#branch=titlebar-position"
+source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git"
+ "titlebar_position.diff::https://github.com/swaywm/sway/compare/master...janza:titlebar-position.diff"
50-systemd-user.conf)
sha512sums=('SKIP'
+ '73ec0b3f4599574bd4b17858957868ea0dfc3a6d0bb34efcf8378a38de5fa947426ee1447b1c2f7bc2ecb67c9ce22d922641815aeb56d641593293203684c792'
'57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e')
provides=("sway")
conflicts=("sway")
@@ -53,6 +55,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare () {
+ cd "$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/titlebar_position.diff"
+}
+
build() {
arch-meson \
-Dsd-bus-provider=libsystemd \