summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordchusovitin2021-06-05 20:13:23 +0300
committerdchusovitin2021-06-05 20:15:09 +0300
commit7292bd65443ecd8304a63b8d72e5d69ce73fcd70 (patch)
tree9b3d0c754ff8fda2690a8e22c3ebc57288d0a0c7
downloadaur-sway-xkb-switcher.tar.gz
Initial (version 0.3.0-1)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7cd03bb0fff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sway-xkb-switcher
+ pkgdesc = Keyboard layout switcher for sway windows
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/nmukhachev/sway-xkb-switcher
+ arch = x86_64
+ license = MIT
+ makedepends = python-pip
+ depends = python-i3ipc
+ source = sway-xkb-switcher-0.3.0.tar.gz::https://github.com/nmukhachev/sway-xkb-switcher/archive/v0.3.0.tar.gz
+ sha256sums = 2c3afee5e891a13340fe8fb2fda81b3c172411d2acd6a50502f9d014133fa773
+
+pkgname = sway-xkb-switcher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d1f029afc33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: dchusovitin <dchusovitin@gmail.com>
+pkgname='sway-xkb-switcher'
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='Keyboard layout switcher for sway windows'
+arch=('x86_64')
+url='https://github.com/nmukhachev/sway-xkb-switcher'
+license=('MIT')
+depends=('python-i3ipc')
+makedepends=('python-pip')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nmukhachev/sway-xkb-switcher/archive/v$pkgver.tar.gz")
+
+sha256sums=('2c3afee5e891a13340fe8fb2fda81b3c172411d2acd6a50502f9d014133fa773')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps --no-compile --no-warn-script-location "./${pkgname}-${pkgver}"
+ python -O -m compileall -q -s ${pkgdir} ${pkgdir}
+}
+