summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2020-01-27 18:12:35 +0200
committerDan Elkouby2020-01-27 18:12:57 +0200
commit15ecac237711091dbba27c22924b58cdaf176a3a (patch)
treeb806ef87384765c61f754c08d5f99fb05af258ba
parent1f41987875f09381916da09d3a5db0212639f364 (diff)
downloadaur-15ecac237711091dbba27c22924b58cdaf176a3a.tar.gz
Update to 1.4
-rw-r--r--.SRCINFO8
-rw-r--r--10-systemd.conf10
-rw-r--r--50-systemd-user.conf7
-rw-r--r--PKGBUILD11
4 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 620a075dbd07..095caca0f685 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sway9
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager (personal build)
- pkgver = 1.2
+ pkgver = 1.4
pkgrel = 4
epoch = 1
url = https://github.com/Streetwalrus/sway9
@@ -34,11 +34,11 @@ pkgbase = sway9
provides = sway
conflicts = sway
backup = etc/sway/config
- source = git+https://github.com/Streetwalrus/sway9.git#commit=a1c3ae39adda7d810c6d740f83e1526be06bc55f
- source = 10-systemd.conf
+ source = git+https://github.com/Streetwalrus/sway9.git#commit=8cbcdc245c8a215279711cc18fc9f2d0a2577933
+ source = 50-systemd-user.conf
validpgpkeys = 9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A
sha512sums = SKIP
- sha512sums = 122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b
+ sha512sums = 57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e
pkgname = sway9
diff --git a/10-systemd.conf b/10-systemd.conf
deleted file mode 100644
index af7484bba3ef..000000000000
--- a/10-systemd.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-#
-# FS#63021
-#
-
-systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XCURSOR_SIZE
-
-if command -v dbus-update-activation-environment >/dev/null 2>&1; then
- dbus-update-activation-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XCURSOR_SIZE
-fi
diff --git a/50-systemd-user.conf b/50-systemd-user.conf
new file mode 100644
index 000000000000..72e5dcd98b02
--- /dev/null
+++ b/50-systemd-user.conf
@@ -0,0 +1,7 @@
+# sway does not set DISPLAY/WAYLAND_DISPLAY in the systemd user environment
+# See FS#63021
+# Adapted from xorg's 50-systemd-user.sh, which achieves a similar goal.
+
+exec systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK
+exec hash dbus-update-activation-environment 2>/dev/null && \
+ dbus-update-activation-environment --systemd DISPLAY WAYLAND_DISPLAY SWAYSOCK
diff --git a/PKGBUILD b/PKGBUILD
index 3a6a82acef02..7366b5572150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Brett Cornwall <ainola@archlinux.org>
pkgname=sway9
-pkgver=1.2
+pkgver=1.4
epoch=1
pkgrel=4
-_commit=a1c3ae39adda7d810c6d740f83e1526be06bc55f
+_commit=8cbcdc245c8a215279711cc18fc9f2d0a2577933
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
arch=(x86_64)
url='https://github.com/Streetwalrus/sway9'
@@ -30,9 +31,9 @@ optdepends=(
'xorg-server-xwayland: X11 support'
)
source=("git+https://github.com/Streetwalrus/$pkgname.git#commit=$_commit"
- "10-systemd.conf")
+ "50-systemd-user.conf")
sha512sums=('SKIP'
- '122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b')
+ '57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e')
validpgpkeys=('9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A') # Drew DeVault
build() {
@@ -44,7 +45,7 @@ build() {
package() {
DESTDIR="$pkgdir" ninja -C build install
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 10-systemd.conf "$pkgdir/etc/sway/conf.d/10-systemd.conf"
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
}
# vim: ts=2 sw=2 et