summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornovenary2021-04-17 23:35:43 +0300
committernovenary2021-04-17 23:35:43 +0300
commit3c1873dab24c6ad029680e256a142a5eb1909c23 (patch)
tree25fce5175c70d1e8237a4a122a06d26b7541ecfb
parent155906edbfaa80e288397466a40b76c22b671f21 (diff)
downloadaur-3c1873dab24c6ad029680e256a142a5eb1909c23.tar.gz
Update to 1.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4fe22c02055..ab0f58d9570b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = sway9
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager (personal build)
- pkgver = 1.5.1
- pkgrel = 3
+ pkgver = 1.6
+ pkgrel = 1
epoch = 1
- url = https://github.com/Streetwalrus/sway9
+ url = https://github.com/9ary/sway9
arch = x86_64
license = MIT
makedepends = git
@@ -31,11 +31,11 @@ pkgbase = sway9
optdepends = swaylock: Screen locker
optdepends = wallutils: Timed wallpapers
optdepends = waybar: Highly customizable bar
- optdepends = xorg-server-xwayland: X11 support
+ optdepends = xorg-xwayland: X11 support
provides = sway
conflicts = sway
backup = etc/sway/config
- source = git+https://github.com/Streetwalrus/sway9.git#commit=c00a05ba48a9d99cf7c1e92d4cc3ccbf57af2313
+ source = git+https://github.com/9ary/sway9.git#commit=6c2f00d6be62c6215baac0c70779fb2ad0307dc4
source = 50-systemd-user.conf
sha512sums = SKIP
sha512sums = 57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e
diff --git a/PKGBUILD b/PKGBUILD
index 369ca2f437a3..8cf77345f0c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
-# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
-# Contributor: Jerome Leclanche <jerome@leclan.ch>
+# Maintainer: novenary <streetwalkermc@gmail.com>
+# Contributor: Brett Cornwall <ainola@archlinux.org>
# Contributor: Maxim Baz <$pkgname at maximbaz dot com>
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
-# Contributor: Brett Cornwall <ainola@archlinux.org>
pkgname=sway9
-pkgver=1.5.1
+pkgver=1.6
epoch=1
-pkgrel=3
-_commit=c00a05ba48a9d99cf7c1e92d4cc3ccbf57af2313
+pkgrel=1
+_commit=6c2f00d6be62c6215baac0c70779fb2ad0307dc4
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
arch=(x86_64)
-url='https://github.com/Streetwalrus/sway9'
+url='https://github.com/9ary/sway9'
license=(MIT)
depends=(
'cairo'
@@ -39,16 +38,16 @@ optdepends=(
'swaylock: Screen locker'
'wallutils: Timed wallpapers'
'waybar: Highly customizable bar'
- 'xorg-server-xwayland: X11 support'
+ 'xorg-xwayland: X11 support'
)
-source=("git+https://github.com/Streetwalrus/$pkgname.git#commit=$_commit"
+source=("git+https://github.com/9ary/$pkgname.git#commit=$_commit"
"50-systemd-user.conf")
sha512sums=('SKIP'
'57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e')
build() {
mkdir -p build
- arch-meson build "$pkgname" -D werror=false -D b_ndebug=true
+ arch-meson build "$pkgname" -D sd-bus-provider=libsystemd -D werror=false -D b_ndebug=true
ninja -C build
}