summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2020-02-21 19:47:53 +0200
committerDan Elkouby2020-02-21 19:47:53 +0200
commit3cf03b72561a3bcdc3e741d017581dab3e98035d (patch)
tree2446ea93146ed474c80018ba3fa9d27a85d85902
parent15ecac237711091dbba27c22924b58cdaf176a3a (diff)
downloadaur-3cf03b72561a3bcdc3e741d017581dab3e98035d.tar.gz
Sync with [community]
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 095caca0f685..704f2909205c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sway9
pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager (personal build)
pkgver = 1.4
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = https://github.com/Streetwalrus/sway9
arch = x86_64
@@ -20,11 +20,11 @@ pkgbase = sway9
depends = swaybg
depends = ttf-font
depends = wlroots
+ optdepends = alacritty: Terminal emulator used by the default config
optdepends = dmenu: Application launcher
- optdepends = i3status: Status line
optdepends = grim: Screenshot utility
+ optdepends = i3status: Status line
optdepends = mako: Lightweight notification daemon
- optdepends = rxvt-unicode: Terminal emulator
optdepends = slurp: Select a region
optdepends = swayidle: Idle management daemon
optdepends = swaylock: Screen locker
diff --git a/PKGBUILD b/PKGBUILD
index 7366b5572150..b8f89d819fe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=sway9
pkgver=1.4
epoch=1
-pkgrel=4
+pkgrel=5
_commit=8cbcdc245c8a215279711cc18fc9f2d0a2577933
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
arch=(x86_64)
@@ -18,11 +18,11 @@ provides=(sway)
conflicts=(sway)
backup=(etc/sway/config)
optdepends=(
+ 'alacritty: Terminal emulator used by the default config'
'dmenu: Application launcher'
- 'i3status: Status line'
'grim: Screenshot utility'
+ 'i3status: Status line'
'mako: Lightweight notification daemon'
- 'rxvt-unicode: Terminal emulator'
'slurp: Select a region'
'swayidle: Idle management daemon'
'swaylock: Screen locker'
@@ -46,6 +46,11 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+
+ for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
+ install -Dm755 "$pkgname-$pkgver/contrib/$util" -t \
+ "$pkgdir/usr/share/$pkgname/scripts"
+ done
}
# vim: ts=2 sw=2 et