summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2019-12-27 16:01:50 +0200
committerDan Elkouby2019-12-27 16:02:10 +0200
commit702717615973098668af0a24d7afce8c65ba4cf3 (patch)
tree339e99cfee1ec272eee736ddd1fd3020ae118ef8
parent20310e07b1a9bda6e6dd04f179791bdf2e03437d (diff)
downloadaur-702717615973098668af0a24d7afce8c65ba4cf3.tar.gz
Move patches to github
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--0001-Don-t-use-git-to-find-the-version.patch30
-rw-r--r--0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch24
-rw-r--r--PKGBUILD36
5 files changed, 11 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98b6f4f4d031..3f41a9328d02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@ pkgbase = sway9
pkgver = 1.2
pkgrel = 2
epoch = 1
- url = https://swaywm.org/
+ url = https://github.com/Streetwalrus/sway9
arch = x86_64
license = MIT
makedepends = git
@@ -34,17 +34,11 @@ pkgbase = sway9
provides = sway
conflicts = sway
backup = etc/sway/config
- source = https://github.com/swaywm/sway/releases/download/1.2/sway-1.2.tar.gz
- source = https://github.com/swaywm/sway/releases/download/1.2/sway-1.2.tar.gz.sig
+ source = git+https://github.com/Streetwalrus/sway9.git#commit=49ba75fd2e9f637ae0ef26545292f4c96aa93888
source = 10-systemd.conf
- source = 0001-Don-t-use-git-to-find-the-version.patch
- source = 0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
validpgpkeys = 9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A
- sha512sums = e3842e0da58a1678289aa24fc84f6841deeea6e9ffe04407525e5b9d62ed177d890133ff07412317c811f5b07a2e5073d14ff59a30e62111f51fc65af0dddb19
sha512sums = SKIP
sha512sums = 122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b
- sha512sums = 9bd8d02b0f05f143a4a18825e52fc0e977675a24f3f590de8a23e2d24eff358af90b4f14f13b737fae8ae4fa02f5dc079817d8a38cdb21f5b423af5812b0dcee
- sha512sums = 65358db9ffe024605c9d8608fa31cdbb2c86a725e57963146aab40b674d7d938e594aabff4cf12598bb63c04c8e6f5d6d13ce72e4bb00708323ef4d1f838a31d
pkgname = sway9
diff --git a/.gitignore b/.gitignore
index 984a66f8ea06..32805676452f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src
pkg
-sway-*.tar.gz*
+sway9
*.pkg.tar*
diff --git a/0001-Don-t-use-git-to-find-the-version.patch b/0001-Don-t-use-git-to-find-the-version.patch
deleted file mode 100644
index 3ab04f584eb6..000000000000
--- a/0001-Don-t-use-git-to-find-the-version.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9ca19e83015df6452acb91cccd7ac92e7e9b890e Mon Sep 17 00:00:00 2001
-From: Dan Elkouby <streetwalkermc@gmail.com>
-Date: Fri, 27 Dec 2019 15:36:23 +0200
-Subject: [PATCH 1/2] Don't use git to find the version
-
----
- meson.build | 7 -------
- 1 file changed, 7 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 6118a6b8..b424adf1 100644
---- a/meson.build
-+++ b/meson.build
-@@ -130,13 +130,6 @@ endif
- add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'c')
-
- version = '"@0@"'.format(meson.project_version())
--if git.found()
-- git_commit_hash = run_command([git.path(), 'describe', '--always', '--tags'])
-- git_branch = run_command([git.path(), 'rev-parse', '--abbrev-ref', 'HEAD'])
-- if git_commit_hash.returncode() == 0 and git_branch.returncode() == 0
-- version = '"@0@ (" __DATE__ ", branch \'@1@\')"'.format(git_commit_hash.stdout().strip(), git_branch.stdout().strip())
-- endif
--endif
- add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
-
- # Compute the relative path used by compiler invocations.
---
-2.24.1
-
diff --git a/0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch b/0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
deleted file mode 100644
index dda43c4ed3f5..000000000000
--- a/0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 49ba75fd2e9f637ae0ef26545292f4c96aa93888 Mon Sep 17 00:00:00 2001
-From: Dan Elkouby <streetwalkermc@gmail.com>
-Date: Fri, 27 Dec 2019 15:21:31 +0200
-Subject: [PATCH 2/2] Don't send wl_pointer_leave when hide_cursor activates
-
----
- sway/input/cursor.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/sway/input/cursor.c b/sway/input/cursor.c
-index c6a332b8..493085ea 100644
---- a/sway/input/cursor.c
-+++ b/sway/input/cursor.c
-@@ -174,7 +174,6 @@ void cursor_rebase_all(void) {
- static void cursor_hide(struct sway_cursor *cursor) {
- wlr_cursor_set_image(cursor->cursor, NULL, 0, 0, 0, 0, 0, 0);
- cursor->hidden = true;
-- wlr_seat_pointer_clear_focus(cursor->seat->wlr_seat);
- }
-
- static int hide_notify(void *data) {
---
-2.24.1
-
diff --git a/PKGBUILD b/PKGBUILD
index fc0091fc31e5..e5e4571d6796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
-_pkgname=sway
pkgname=sway9
pkgver=1.2
epoch=1
pkgrel=2
+_commit=49ba75fd2e9f637ae0ef26545292f4c96aa93888
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
arch=(x86_64)
-url='https://swaywm.org/'
+url='https://github.com/Streetwalrus/sway9'
license=(MIT)
depends=(cairo gdk-pixbuf2 json-c pango pcre swaybg ttf-font wlroots)
makedepends=(git meson ninja scdoc setconf wayland-protocols)
@@ -29,41 +29,21 @@ optdepends=(
'waybar: Highly customizable bar'
'xorg-server-xwayland: X11 support'
)
-source=("https://github.com/swaywm/sway/releases/download/$pkgver/sway-$pkgver.tar.gz"
- "https://github.com/swaywm/sway/releases/download/$pkgver/sway-$pkgver.tar.gz.sig"
- "10-systemd.conf"
- "0001-Don-t-use-git-to-find-the-version.patch"
- "0002-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch")
-sha512sums=('e3842e0da58a1678289aa24fc84f6841deeea6e9ffe04407525e5b9d62ed177d890133ff07412317c811f5b07a2e5073d14ff59a30e62111f51fc65af0dddb19'
- 'SKIP'
- '122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b'
- '9bd8d02b0f05f143a4a18825e52fc0e977675a24f3f590de8a23e2d24eff358af90b4f14f13b737fae8ae4fa02f5dc079817d8a38cdb21f5b423af5812b0dcee'
- '65358db9ffe024605c9d8608fa31cdbb2c86a725e57963146aab40b674d7d938e594aabff4cf12598bb63c04c8e6f5d6d13ce72e4bb00708323ef4d1f838a31d')
+source=("git+https://github.com/Streetwalrus/$pkgname.git#commit=$_commit"
+ "10-systemd.conf")
+sha512sums=('SKIP'
+ '122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b')
validpgpkeys=('9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A') # Drew DeVault
-prepare() {
- cd "$_pkgname-$pkgver"
-
- # From the linux-mainline PKGBUILD
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
- done
-}
-
build() {
mkdir -p build
- arch-meson build "$_pkgname-$pkgver" -D werror=false -D b_ndebug=true
+ arch-meson build "$pkgname" -D werror=false -D b_ndebug=true
ninja -C build
}
package() {
DESTDIR="$pkgdir" ninja -C build install
- install -Dm644 "$_pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm755 10-systemd.conf "$pkgdir/etc/sway/conf.d/10-systemd.conf"
}