summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-09 15:51:48 -0500
committerVincent Grande2020-12-09 15:51:48 -0500
commit58aee8e60a34577f5e23b2226b6d428950e2d46e (patch)
tree8f006f5e9214bb95af844c010fa61c5d166caa41
downloadaur-58aee8e60a34577f5e23b2226b6d428950e2d46e.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bead8d537a6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = swaybg-minimal-git
+ pkgdesc = Wallpaper tool for Wayland compositors
+ pkgver = r95.a8f109a
+ pkgrel = 1
+ url = https://swaywm.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = wayland-protocols
+ depends = wayland
+ depends = cairo
+ provides = swaybg
+ conflicts = swaybg
+ source = swaybg-minimal::git+https://github.com/swaywm/swaybg.git#branch=master
+ sha1sums = SKIP
+
+pkgname = swaybg-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecb656c78add
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Taran Lynn <taranlynn0gmail.com>
+
+pkgname=swaybg-minimal-git
+_pkgname=swaybg
+pkgver=r95.a8f109a
+pkgrel=1
+license=("MIT")
+pkgdesc="Wallpaper tool for Wayland compositors"
+makedepends=(
+ 'meson'
+ 'git'
+# 'scdoc'
+ 'wayland-protocols'
+# 'gdk-pixbuf2'
+)
+depends=(
+ "wayland" "cairo"
+)
+
+arch=("i686" "x86_64")
+url="https://swaywm.org"
+source=("${pkgname%-*}::git+https://github.com/swaywm/swaybg.git#branch=master")
+sha1sums=("SKIP")
+provides=("swaybg")
+conflicts=("swaybg")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ arch-meson "${_pkgname}" build -Dgdk-pixbuf=disabled -Dman-pages=disabled
+ meson compile -C build
+}
+
+#check() {
+# meson test -C build
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}