summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexawolf2020-03-01 07:27:01 +0000
committerHexawolf2020-03-01 07:29:59 +0000
commit3d3085baebe0598c3b368a045793b82c2670b3d0 (patch)
treebd014e276d5cf623fd17503a0e59082045402f64
downloadaur-3d3085baebe0598c3b368a045793b82c2670b3d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19a13915c3ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = swaylay-git
+ pkgdesc = Keyboard layouts monitoring utility for Sway WM
+ pkgver = r7.d29a93a
+ pkgrel = 1
+ url = https://hexawolf.dev/posts/swaylay/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ makedepends = git
+ depends = json-c
+ depends = sway
+ provides = swaylay
+ conflicts = swaylay
+ conflicts = swaylayout
+ options = strip
+ source = swaylay::git+https://github.com/Hexawolf/swaylay.git
+ sha512sums = SKIP
+
+pkgname = swaylay-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2ad630d2e39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hexawolf <hexawolf@protonmail.com>
+pkgname=swaylay-git
+_pkgname=swaylay
+pkgver=r7.d29a93a
+pkgrel=1
+license=("MIT")
+pkgdesc="Keyboard layouts monitoring utility for Sway WM"
+makedepends=("meson" "ninja" "git")
+depends=("json-c" "sway")
+arch=("i686" "x86_64")
+url="https://hexawolf.dev/posts/swaylay/"
+source=("${pkgname%-*}::git+https://github.com/Hexawolf/swaylay.git")
+sha512sums=('SKIP')
+provides=("swaylay")
+conflicts=("swaylay" "swaylayout")
+options=(strip)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+}
+
+build() {
+ cd "$_pkgname"
+ meson \
+ --buildtype release \
+ -Dwerror=false \
+ --prefix /usr \
+ "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}