summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Bassi2019-02-23 12:01:56 -0800
committerCaleb Bassi2019-02-23 12:02:07 -0800
commit09e9ab033a958d587513d53f591d191770e3ac12 (patch)
tree5ca91c183dff5b8b3974c7d963653c58aa69c105
downloadaur-09e9ab033a958d587513d53f591d191770e3ac12.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53b881dc3086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = swaylock-blur-bin
+ pkgdesc = A small Rust program that runs swaylock and sets the image to a blurred screenshot of the desktop
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/cjbassi/gotop
+ arch = x86_64
+ license = MIT
+ provides = swaylock-blur
+ conflicts = swaylock-blur
+ source = https://github.com/cjbassi/swaylock-blur/releases/download/0.2.1/swaylock-blur-0.2.1-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = a31b566ad07ef4728b2a2d5f8f1a66a7f907a6791496ac17249a32d72fa34411
+
+pkgname = swaylock-blur-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9067e8e47aa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Caleb Bassi <calebjbassi@gmail.com>
+
+pkgname=swaylock-blur-bin
+_pkgname=${pkgname%-bin}
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A small Rust program that runs swaylock and sets the image to a blurred screenshot of the desktop"
+arch=("x86_64")
+url="https://github.com/cjbassi/gotop"
+license=("MIT")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("https://github.com/cjbassi/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=("a31b566ad07ef4728b2a2d5f8f1a66a7f907a6791496ac17249a32d72fa34411")
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}