summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Bassi2018-12-26 15:45:47 -0800
committerCaleb Bassi2018-12-26 15:45:47 -0800
commitd032f87e7156408d6137a5514e55a8b8a992845f (patch)
tree3c17c8376b7e8aaedbaa48ee550e4e576f9f886d
downloadaur-d032f87e7156408d6137a5514e55a8b8a992845f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa25d342211b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = swaylock-blur-git
+ pkgdesc = Small swaylock wrapper written in bash to set a blurred image of the desktop as the background
+ pkgver = r1.943d40e
+ pkgrel = 1
+ url = https://github.com/cjbassi/swaylock-blur
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = sway
+ depends = imagemagick
+ depends = grim
+ provides = swaylock-blur
+ conflicts = swaylock-blur
+ source = git+https://github.com/cjbassi/swaylock-blur
+ md5sums = SKIP
+
+pkgname = swaylock-blur-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..469a87676d42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caleb Bassi <calebjbassi@gmail.com>
+
+pkgname=swaylock-blur-git
+_pkgname=${pkgname%-git}
+pkgver=r1.943d40e
+pkgrel=1
+pkgdesc="Small swaylock wrapper written in bash to set a blurred image of the desktop as the background"
+arch=("any")
+url="https://github.com/cjbassi/swaylock-blur"
+license=("MIT")
+depends=("sway"
+ "imagemagick"
+ "grim")
+makedepends=("git")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("git+${url}")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin/
+ install ${srcdir}/${_pkgname}/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+}