summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoritsme2023-12-16 17:15:27 +0700
committeritsme2023-12-16 17:15:27 +0700
commita7c41204ea30d5f2e1cdfe543b48463c835784cb (patch)
tree95b538f52ef741a56b858b2c39b2afc305cb6985
parent0176ddb7453f1ed6e4f524f6f8b276f6f949d53b (diff)
downloadaur-a7c41204ea30d5f2e1cdfe543b48463c835784cb.tar.gz
1.7.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb700e604779..76148cba06c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swaylock-effects
pkgdesc = A fancier screen locker for Wayland.
- pkgver = 1.6.4
- pkgrel = 2
+ pkgver = 1.7.0.0
+ pkgrel = 1
url = https://github.com/mortie/swaylock-effects
arch = i686
arch = x86_64
@@ -18,10 +18,7 @@ pkgbase = swaylock-effects
depends = gdk-pixbuf2
depends = pam
provides = swaylock
- provides = swaylock-effects
- conflicts = swaylock
- conflicts = swaylock-effects-git
- source = https://github.com/mortie/swaylock-effects/archive/v1.6-4.tar.gz
- sha256sums = 4f82c9d875ce20f1d58227ef65db60aacccb3fb29ce67c0f744849da68e82b20
+ source = https://github.com/jirutka/swaylock-effects/archive/v1.7.0.0.tar.gz
+ sha256sums = e94d79e189602694bedfbafb553ce3c6c976426e16f76d93bf7e226dc2876eb6
pkgname = swaylock-effects
diff --git a/PKGBUILD b/PKGBUILD
index ae288f8223ec..b21783920517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: itsme <mymail@ishere.ru>
pkgname=swaylock-effects
-pkgver=1.6.4
-_pkgver=1.6-4
-pkgrel=2
+pkgver=1.7.0.0
+pkgrel=1
pkgdesc="A fancier screen locker for Wayland."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/mortie/$pkgname"
license=('MIT')
depends=('libxkbcommon' 'cairo' 'gdk-pixbuf2' 'pam')
makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland' 'wayland-protocols')
-provides=('swaylock' 'swaylock-effects')
-conflicts=('swaylock' 'swaylock-effects-git')
-source=("https://github.com/mortie/$pkgname/archive/v$_pkgver.tar.gz")
-sha256sums=('4f82c9d875ce20f1d58227ef65db60aacccb3fb29ce67c0f744849da68e82b20')
+provides=('swaylock')
+source=("https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('e94d79e189602694bedfbafb553ce3c6c976426e16f76d93bf7e226dc2876eb6')
build() {
- cd "$pkgname-$_pkgver"
+ cd "$pkgname-$pkgver"
meson build --prefix=/usr
ninja -C build
}
package() {
- cd "$pkgname-$_pkgver"
+ cd "$pkgname-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
}