summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilbus2019-01-14 11:14:26 +0100
committergilbus2019-01-14 11:14:26 +0100
commit22a17b838e7ab6b2e9837e97fdd2fee00f456e8d (patch)
tree2fbb5aa5807fe8fe43d3295dadeb8fd93ecd43e3
downloadaur-22a17b838e7ab6b2e9837e97fdd2fee00f456e8d.tar.gz
Adapted PKGBUILD from sway-git
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13a6274214b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = swaylock-git
+ pkgdesc = Screen locker for Wayland
+ pkgver = r152.aab44df
+ pkgrel = 1
+ url = https://swaywm.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ depends = wayland
+ depends = wlroots-git
+ depends = pango
+ depends = cairo
+ depends = pam
+ optdepends = gdk-pixbuf2: For background images other than PNG
+ provides = swaylock
+ options = debug
+ options = !strip
+ source = swaylock::git+https://github.com/swaywm/swaylock.git
+ sha1sums = SKIP
+
+pkgname = swaylock-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d63c3288fa0e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+swaylock*.tar*
+src/
+pkg/
+swaylock/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c579fa0c5b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: gilbus <aur(AT)tinkershell.eu>
+pkgname=swaylock-git
+_pkgname=swaylock
+pkgver=r152.aab44df
+pkgrel=1
+license=("MIT")
+pkgdesc="Screen locker for Wayland "
+makedepends=("meson" "git" "scdoc" "wayland-protocols")
+depends=(
+ "wayland" "wlroots-git" "pango" "cairo" "pam"
+)
+optdepends=(
+ "gdk-pixbuf2: For background images other than PNG"
+)
+arch=("i686" "x86_64")
+url="https://swaywm.org"
+source=("${pkgname%-*}::git+https://github.com/swaywm/swaylock.git")
+sha1sums=("SKIP")
+provides=("swaylock")
+#conflicts=("swaylock")
+options=(debug !strip)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ meson -Dwerror=false --prefix /usr "$srcdir/build"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="$pkgdir/" ninja -C "$srcdir/build" install
+}