summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitaliy Berdinskikh2019-03-23 00:25:24 +0200
committerVitaliy Berdinskikh2019-03-23 00:25:24 +0200
commit1188e9c5669baa7e60eb47c98043034068494093 (patch)
treedbd400ad9f3049ded341585dede80f6856d28811
parentb769e52afc65fb9f3945c7e835ac64e53e01d698 (diff)
downloadaur-1188e9c5669baa7e60eb47c98043034068494093.tar.gz
Now it works with wl-clipboard
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f62463466315..c82945de61ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swayshot
pkgdesc = Put your screenshots to XDG_PICTURES_DIR folder
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://gitlab.com/racy/swayshot
arch = any
license = Apache
@@ -10,11 +10,12 @@ pkgbase = swayshot
depends = grim
depends = slurp
depends = jq
- optdepends = xsel: copy the full path to clipboard (or xclip)
- optdepends = xclip: copy the full path to clipboard (or xsel)
+ optdepends = wl-clipboard: copy the full path to clipboard
+ optdepends = xsel: copy the full path to clipboard
+ optdepends = xclip: copy the full path to clipboard
conflicts = swaygrab-helper
- source = https://gitlab.com/racy/swayshot/-/archive/2.0.1/swayshot-2.0.1.tar.bz2
- sha256sums = 694c77150c93d43d43c25281a94aea0d67d19d38bf9a2fe105d5db5a1306f4b6
+ source = https://gitlab.com/racy/swayshot/-/archive/2.1.0/swayshot-2.1.0.tar.bz2
+ sha256sums = 4d20f78e16d6f733c0d047f5b1fd6c76b8470c5981b09cf421fff3328a90e1d0
pkgname = swayshot
diff --git a/PKGBUILD b/PKGBUILD
index f6675ab279d5..1759ebb8b639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Vitaliy Berdinskikh <ur6lad at gmail dot com>
pkgname=swayshot
-pkgver=2.0.1
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc='Put your screenshots to XDG_PICTURES_DIR folder'
arch=('any')
url='https://gitlab.com/racy/swayshot'
license=('Apache')
depends=('sway' 'xdg-user-dirs' 'grim' 'slurp' 'jq')
-optdepends=('xsel: copy the full path to clipboard (or xclip)'
- 'xclip: copy the full path to clipboard (or xsel)')
+optdepends=('wl-clipboard: copy the full path to clipboard'
+ 'xsel: copy the full path to clipboard'
+ 'xclip: copy the full path to clipboard')
conflicts=('swaygrab-helper')
source=(https://gitlab.com/racy/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('694c77150c93d43d43c25281a94aea0d67d19d38bf9a2fe105d5db5a1306f4b6')
+sha256sums=('4d20f78e16d6f733c0d047f5b1fd6c76b8470c5981b09cf421fff3328a90e1d0')
package() {
cd "$srcdir"/$pkgname-$pkgver