summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Chamberlain2020-11-13 18:42:22 +1100
committerChris Chamberlain2020-11-13 18:42:22 +1100
commitac0859b07121cd7df1a1877ab7204b26ab2a38c4 (patch)
treeb8d743a5b735f3ee1eef627217f0fe581e6f9031
downloadaur-ac0859b07121cd7df1a1877ab7204b26ab2a38c4.tar.gz
Initial package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7f95647b4fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = swayshot-no-bash-git
+ pkgdesc = Sway screenshots: screen, window or region - removed bashisms
+ pkgver = r21.b6f87b8
+ pkgrel = 1
+ url = https://gitlab.com/neon64/swayshot
+ arch = any
+ license = Apache
+ depends = sway
+ depends = xdg-user-dirs
+ depends = grim
+ depends = slurp
+ depends = jq
+ optdepends = wl-clipboard: copy the full path to clipboard
+ optdepends = xsel: copy the full path to clipboard
+ optdepends = xclip: copy the full path to clipboard
+ provides = swayshot
+ conflicts = swaygrab-helper
+ conflicts = swayshot
+ source = git+https://gitlab.com/neon64/swayshot.git
+ sha256sums = SKIP
+
+pkgname = swayshot-no-bash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fc315112a11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vitaliy Berdinskikh <ur6lad at gmail dot com>
+# Modified by Chris Chamberlain <chris at chamberlain dot id dot au>
+pkgname=swayshot-no-bash-git
+_pkgname=swayshot
+pkgver=r21.b6f87b8
+pkgrel=1
+pkgdesc='Sway screenshots: screen, window or region - removed bashisms'
+arch=('any')
+url='https://gitlab.com/neon64/swayshot'
+license=('Apache')
+depends=('sway' 'xdg-user-dirs' 'grim' 'slurp' 'jq')
+optdepends=('wl-clipboard: copy the full path to clipboard'
+ 'xsel: copy the full path to clipboard'
+ 'xclip: copy the full path to clipboard')
+provides=('swayshot')
+conflicts=('swaygrab-helper' 'swayshot')
+source=(git+https://gitlab.com/neon64/swayshot.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"/$_pkgname
+
+ install -d "$pkgdir"/etc/sway/config.d
+ install -m 644 $_pkgname.config "$pkgdir"/etc/sway/config.d/$_pkgname
+ install -d "$pkgdir"/usr/bin
+ install -m 755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
+}
+