summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2024-02-19 21:12:22 +0100
committerMichał Wojdyła2024-02-19 21:12:22 +0100
commit9ae7588e369f03062737ab825ddf53d2f5580120 (patch)
tree429350a773f1f6c9c9666a3dc3cb8eece25e8d6b
downloadaur-9ae7588e369f03062737ab825ddf53d2f5580120.tar.gz
upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c833de05576
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = swbis
+ pkgdesc = software packaging -- again
+ pkgver = 1.13.3
+ pkgrel = 1
+ url = https://www.gnu.org/software/swbis/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = bash
+ depends = gawk
+ depends = gcc-libs
+ depends = glibc
+ optdepends = inetutils
+ source = https://ftp.gnu.org/gnu/swbis/swbis-1.13.3.tar.gz
+ md5sums = 0106914abde67de1c44cf67d2a1be557
+
+pkgname = swbis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c10b7d65d672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+pkgname=swbis
+pkgver=1.13.3
+pkgrel=1
+pkgdesc="software packaging -- again"
+arch=(i686 x86_64)
+url='https://www.gnu.org/software/swbis/'
+license=('GPL3')
+depends=(bash gawk gcc-libs glibc)
+optdepends=(inetutils)
+source=(https://ftp.gnu.org/gnu/swbis/$pkgname-$pkgver.tar.gz)
+md5sums=('0106914abde67de1c44cf67d2a1be557')
+
+build(){
+cd "$pkgname-$pkgver"
+./configure --prefix=/usr --libexecdir=/usr/lib
+make -j1
+}
+package(){
+cd "$pkgname-$pkgver"
+make DESTDIR="$pkgdir/" install
+}