aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkashirin.alex2021-02-05 15:00:10 +0100
committerkashirin.alex2021-02-05 15:00:10 +0100
commit01da93a75fb761b10c2c607e6e7ee39bd36d0254 (patch)
treefe3105b206785996ddcbb3bebbaec7288ea7d2fe
downloadaur-01da93a75fb761b10c2c607e6e7ee39bd36d0254.tar.gz
Initial SWC-DB FS Interface library package
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD63
-rwxr-xr-xREADME.md23
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..351ad7a499d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = swcdb-lib-fs
+ pkgdesc = The SWC-DB File System Interface library
+ pkgver = 0.4.16
+ pkgrel = 1
+ url = https://www.swcdb.org
+ install = README.md
+ arch = x86_64
+ groups = swcdb
+ license = GPLv3
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ makedepends = swcdb-lib-core
+ depends = swcdb-env
+ depends = swcdb-lib-core
+ provides = libswcdb_fs.so
+ source = swcdb-lib-fs-0.4.16-source::git+https://github.com/kashirin-alex/swc-db.git#tag=v0.4.16
+ sha256sums = SKIP
+
+pkgname = swcdb-lib-fs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..de4bf84f4dc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Alex Kashirin <kashirin.alex@gmail.com>
+
+_group_name="swcdb"
+_sub_name="lib-fs"
+
+pkgname=${_group_name}-${_sub_name}
+pkgver=0.4.16
+pkgrel=1
+pkgdesc="The SWC-DB File System Interface library"
+arch=("x86_64")
+
+groups=($_group_name)
+provides=(
+ libswcdb_fs.so
+)
+
+url="https://www.swcdb.org"
+license=('GPLv3')
+
+
+depends=(
+ 'swcdb-env'
+ 'swcdb-lib-core'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'make'
+ 'gcc'
+ 'swcdb-lib-core'
+)
+
+optdepends=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=README.md
+changelog=
+
+
+source=(
+ $pkgname-$pkgver-source::git+https://github.com/kashirin-alex/swc-db.git#tag=v$pkgver
+)
+sha256sums=('SKIP')
+
+
+build() {
+ mkdir -p $pkgname-$pkgver-build;
+ cd $pkgname-$pkgver-build;
+
+ cmake ../$pkgname-$pkgver-source \
+ -DO_LEVEL=3 -DSWC_BUILD_PKG=${_sub_name} \
+ -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=$pkgdir/usr \
+ -DCMAKE_BUILD_TYPE=Release;
+ make -j$((`grep -c processor < /proc/cpuinfo || echo 1`));
+}
+
+
+package() {
+ cd $pkgname-$pkgver-build;
+ make install;
+}
diff --git a/README.md b/README.md
new file mode 100755
index 000000000000..ccf8dcb61b40
--- /dev/null
+++ b/README.md
@@ -0,0 +1,23 @@
+
+
+
+#### Creating the `swcdb-lib-fs` Package
+
+* Clone the package from AUR:
+```
+git clone https://aur.archlinux.org/swcdb-lib-fs.git;
+```
+
+
+* Configure, Build and Create the Package:
+```
+# while at the folder of `PKGBUILD`
+cd swcdb-lib-fs;
+chmod -R 777 ./;
+
+sudo -u swcdb_builder makepkg --printsrcinfo > .SRCINFO;
+sudo -u swcdb_builder makepkg -s -r;
+
+# Install
+sudo -u swcdb_builder makepkg -i;
+```