summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2015-08-06 20:06:52 +0800
committerRains2015-08-06 20:06:52 +0800
commitbca0dd6b5f76d7d383fb7e9eabc1782f7eff98b3 (patch)
treedf9a6fede3ff151146942c98b7bcce71e3bfa32f
downloadaur-bca0dd6b5f76d7d383fb7e9eabc1782f7eff98b3.tar.gz
init version
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2ad35355014
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = swconfig
+ pkgdesc = project to package the swconfig utility from OpenWRT for archlinuxarm on BPi-R1
+ pkgver = 20150806
+ pkgrel = 1
+ url = https://github.com/rains31/swconfig
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ makedepends = gcc
+ makedepends = linux-headers
+ depends = libnl
+ provides = swconfig
+ conflicts = swconfig
+ source = git+https://github.com/rains31/swconfig.git
+ sha1sums = SKIP
+
+pkgname = swconfig
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62d30f9218cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d6afb15f1cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=swconfig
+pkgver=20150806
+pkgrel=1
+pkgdesc="project to package the swconfig utility from OpenWRT for archlinuxarm on BPi-R1"
+url="https://github.com/rains31/swconfig"
+license=('GPL2')
+depends=('libnl')
+makedepends=('git' 'gcc' 'linux-headers')
+provides=(${pkgname})
+conflicts=(${pkgname})
+options=()
+arch=('armv7h')
+source=(git+https://github.com/rains31/${pkgname}.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make install DESTDIR=$pkgdir
+}