summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-27 16:40:02 +0200
committerGoliathLabs2020-05-27 16:40:02 +0200
commit968c5e7e9eaa398a4104a54bd12e56e909c00291 (patch)
tree5acf6551a6b043f7d209677305dad312c0e3790a
parentdd2fc4842702e96ae6ac37b635c04559fd7de842 (diff)
downloadaur-968c5e7e9eaa398a4104a54bd12e56e909c00291.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 461222c81f99..ed86fbc7775a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
-# Generated by mksrcinfo v8
-# Wed Jan 27 16:39:01 UTC 2016
pkgbase = sweeper-frameworks-git
pkgdesc = System Cleaner
- pkgver = r328.37cb09f
+ pkgver = r487.4ab73f4
pkgrel = 1
- url = https://www.kde.org/applications/utilities/sweeper
+ url = https://kde.org/applications/utilities/sweeper
arch = i686
arch = x86_64
groups = kde-applications
- groups = kdeutils
+ groups = kde-utilities
license = GPL
+ license = LGPL
+ license = FDL
makedepends = extra-cmake-modules
makedepends = kdoctools
- depends = kdelibs4support
- depends = kinit
+ depends = kactivities-stats
+ depends = kio
provides = sweeper
conflicts = kdeutils-sweeper
conflicts = sweeper
replaces = kdeutils-sweeper
- source = git://anongit.kde.org/sweeper.git#branch=frameworks
+ source = git+https://github.com/KDE/sweeper.git
sha256sums = SKIP
pkgname = sweeper-frameworks-git
diff --git a/PKGBUILD b/PKGBUILD
index 05a582563412..013ec4109465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,42 @@
-# Maintainer: Mladen Pejaković
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Mladen Pejaković
pkgname=sweeper-frameworks-git
-pkgver=r328.37cb09f
+pkgver=r487.4ab73f4
pkgrel=1
pkgdesc='System Cleaner'
+url='https://kde.org/applications/utilities/sweeper'
arch=(i686 x86_64)
-url='https://www.kde.org/applications/utilities/sweeper'
-license=(GPL)
-depends=('kdelibs4support' 'kinit')
-makedepends=('extra-cmake-modules' 'kdoctools')
+license=(GPL LGPL FDL)
+depends=(kactivities-stats kio)
+makedepends=(extra-cmake-modules kdoctools)
+groups=(kde-applications kde-utilities)
conflicts=('kdeutils-sweeper' 'sweeper')
replaces=('kdeutils-sweeper')
provides=('sweeper')
-groups=('kde-applications' 'kdeutils')
-source=("git://anongit.kde.org/sweeper.git#branch=frameworks")
+source=("git+https://github.com/KDE/sweeper.git")
sha256sums=('SKIP')
pkgver() {
- cd sweeper
+ cd $srcdir/sweeper
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
+ cd $srcdir/sweeper
mkdir -p build
}
build() {
- cd build
- cmake ../sweeper \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TESTING=OFF \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cd $srcdir/sweeper/build
+ cmake ../ \
+ -DBUILD_TESTING=OFF
make
}
package() {
- cd build
+ cd $srcdir/sweeper/build
make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING.LIB "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}