summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShinyzenith2022-06-15 11:11:48 +0530
committerShinyzenith2022-06-15 11:11:48 +0530
commit6f707f2e5ae49e0accf9542fed53c41665e48efb (patch)
treeefb4a62dfc968a9e0c66bf5e3ae3593c1e7e9b12
parent41b88171f94764006b14462b64e057d7d3a1364e (diff)
downloadaur-6f707f2e5ae49e0accf9542fed53c41665e48efb.tar.gz
push
Signed-off-by: Shinyzenith <aakashsensharma@gmail.com>
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 268745891067..1898f3597581 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = swhkd-git
makedepends = rustup
makedepends = make
makedepends = git
+ makedepends = scdoc
depends = polkit
conflicts = swhkd-musl-git
source = swhkd::git+https://github.com/waycrate/swhkd
diff --git a/PKGBUILD b/PKGBUILD
index b3dfea608089..557dbf20c1f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,23 +10,29 @@ url="https://github.com/waycrate/swhkd"
pkgdesc="A display server independent hotkey daemon inspired by sxhkd."
license=('BSD')
depends=('polkit')
-makedepends=('rustup' 'make' 'git')
+makedepends=('rustup' 'make' 'git' 'scdoc')
conflicts=('swhkd-musl-git')
source=("$_pkgname::git+https://github.com/waycrate/$_pkgname")
sha256sums=('SKIP')
build(){
cd "$_pkgname"
+ scdoc < ./swhkd.1.scd > swhkd.1.gz
+ scdoc < ./swhks.1.scd > swhks.1.gz
+ scdoc < ./swhkd.5.scd > swhkd.5.gz
+ scdoc < ./swhkd-keys.5.scd > swhkd-keys.5.gz
make setup
- make glibc
+ make
}
package() {
cd "$_pkgname"
- install -Dm 755 ./bin/swhkd "$pkgdir/usr/bin/swhkd"
- install -Dm 755 ./bin/swhks "$pkgdir/usr/bin/swhks"
+ install -Dm 755 ./target/release/swhkd "$pkgdir/usr/bin/swhkd"
+ install -Dm 755 ./target/release/swhks "$pkgdir/usr/bin/swhks"
install -Dm 644 -o root ./com.github.swhkd.pkexec.policy -t "$pkgdir/usr/share/polkit-1/actions"
+ install -Dm 644 ./*.1.gz -t "$pkgdir/usr/share/man/man1/"
+ install -Dm 644 ./*.5.gz -t "$pkgdir/usr/share/man/man5/"
}
pkgver() {