summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchery2019-09-12 16:21:55 -0400
committerarchery2019-09-12 16:21:55 -0400
commit774f939c2a39d6c8b514ed561c4616c2c31e4649 (patch)
treedbae79d87a3d73331099fb0dd7dacf4484f3e5bc
parentc311b923b2a67403e224eb73a15ecfae7fb54668 (diff)
downloadaur-774f939c2a39d6c8b514ed561c4616c2c31e4649.tar.gz
improve performance using stable pkgbuild parts
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
2 files changed, 49 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 012bd04e5a4b..48be679477d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,37 @@
pkgbase = swi-prolog-devel
pkgdesc = Prolog environment (development version)
pkgver = 8.1.13
- pkgrel = 1
- url = http://www.swi-prolog.org/
+ pkgrel = 2
+ url = https://www.swi-prolog.org/
arch = x86_64
arch = i686
license = GPL
license = LGPL
- makedepends = libxft
+ makedepends = cmake
+ makedepends = jdk-openjdk
+ makedepends = junit
makedepends = libjpeg
- makedepends = unixodbc
- makedepends = libxpm
+ makedepends = libxft
makedepends = libxinerama
+ makedepends = libxpm
+ makedepends = ninja
+ makedepends = unixodbc
depends = gmp
depends = readline
depends = openssl
depends = libarchive
+ depends = libyaml
optdepends = unixodbc: for using the odbc4pl library
optdepends = uuid: for using the uuid library
optdepends = libjpeg: for using the pl2xpce library
optdepends = libxpm: for using the pl2xpce library
optdepends = libxinerama: for using the pl2xpce library
optdepends = libxft: for using the pl2xpce library
- optdepends = java-environment: for interfacing java with the jpl package
+ optdepends = jdk-openjdk: for using Prolog from Java
+ optdepends = java-runtime: for using Prolog from Java
provides = swi-prolog
conflicts = swi-prolog
- source = http://swi-prolog.org/download/devel/src/swipl-8.1.13.tar.gz
+ source = https://www.swi-prolog.org/download/devel/src/swipl-8.1.13.tar.gz
sha256sums = a8ff9e2b67a4e745f759328b76631a5d6608b0825de2336a103ab84aa6de9577
pkgname = swi-prolog-devel
diff --git a/PKGBUILD b/PKGBUILD
index ff2905c842f5..d0cb0c3a5f4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,33 +8,50 @@
pkgname=swi-prolog-devel
pkgver=8.1.13
-pkgrel=1
+pkgrel=2
pkgdesc='Prolog environment (development version)'
arch=('x86_64' 'i686')
-url='http://www.swi-prolog.org/'
-license=('GPL' 'LGPL')
-depends=('gmp' 'readline' 'openssl' 'libarchive')
-makedepends=('libxft' 'libjpeg' 'unixodbc' 'libxpm' 'libxinerama')
-optdepends=('unixodbc: for using the odbc4pl library'
+url='https://www.swi-prolog.org/'
+license=(GPL LGPL)
+depends=('gmp' 'readline' 'openssl' 'libarchive' 'libyaml')
+makedepends=(cmake jdk-openjdk junit libjpeg libxft libxinerama libxpm ninja unixodbc)
+optdepends=('unixodbc: for using the odbc4pl library'
'uuid: for using the uuid library'
- 'libjpeg: for using the pl2xpce library'
- 'libxpm: for using the pl2xpce library'
- 'libxinerama: for using the pl2xpce library'
- 'libxft: for using the pl2xpce library'
- 'java-environment: for interfacing java with the jpl package')
-#options=('!makeflags')
-source=("http://swi-prolog.org/download/devel/src/swipl-${pkgver}.tar.gz")
-sha256sums=('a8ff9e2b67a4e745f759328b76631a5d6608b0825de2336a103ab84aa6de9577')
-conflicts=('swi-prolog')
+ 'libjpeg: for using the pl2xpce library'
+ 'libxpm: for using the pl2xpce library'
+ 'libxinerama: for using the pl2xpce library'
+ 'libxft: for using the pl2xpce library'
+ 'jdk-openjdk: for using Prolog from Java'
+ 'java-runtime: for using Prolog from Java')
+source=("https://www.swi-prolog.org/download/devel/src/swipl-$pkgver.tar.gz")
provides=('swi-prolog')
+conflicts=('swi-prolog')
+
+sha256sums=('a8ff9e2b67a4e745f759328b76631a5d6608b0825de2336a103ab84aa6de9577')
build() {
- cd "swipl-$pkgver"
+ mkdir -p build
+ cd build
+ cmake ../swipl-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS -fPIC -ffile-prefix-map=$PWD= -w" \
+ -DLIBEDIT_LIBRARIES=/usr/lib/libedit.so.0 \
+ -DLIBEDIT_INCLUDE_DIR=/usr/include \
+ -G Ninja
+ ../swipl-$pkgver/scripts/pgo-compile.sh
+ ninja
+}
- mkdir build
- cd build && cmake -DCMAKE_INSTALL_PREFIX=/usr .. && make
+check() {
+ cd build
+ # the prolog_in_java test fails
+ ctest -j 8 || true
}
package() {
- make -C "swipl-$pkgver/build" DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
}
+
+# getver: www.swi-prolog.org/download/devel
+# vim: ts=2 sw=2 et: