summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Gonzalez2021-07-01 16:13:33 -0500
committerRyan Gonzalez2021-07-01 16:13:33 -0500
commit329e7f62cae280dfe20d8da4167836833f3ee6e5 (patch)
tree3aac4d1e5343c6905e3473fdd6fe49ddbf61ba6d
parent9a3b7077f96156bb1de7a47df7ddb003015aca32 (diff)
downloadaur-329e7f62cae280dfe20d8da4167836833f3ee6e5.tar.gz
Update to 5.4.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 518b6d562d3e..443438d43435 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = swift-bin
pkgdesc = Binary builds of the Swift programming language
- pkgver = 5.4
+ pkgver = 5.4.2
pkgrel = 1
url = https://swift.org
arch = x86_64
license = apache
makedepends = patchelf
- makedepends = rpmextract
depends = libutil-linux
depends = libxml2
depends = python36
provides = swift-language
replaces = swift-language-bin
options = !strip
- source = https://swift.org/builds/swift-5.4-release/centos8/swift-5.4-RELEASE/swift-5.4-RELEASE-centos8.tar.gz
- sha256sums = f282aec33e1d2c74f1b5804eb437688c39406ad21511b8ee93cec5262c921cfe
+ source = https://swift.org/builds/swift-5.4.2-release/centos8/swift-5.4.2-RELEASE/swift-5.4.2-RELEASE-centos8.tar.gz
+ sha256sums = 48997efc0d3b5a87082609b2d2bab21e421e711427386def6b6e761e5491167f
pkgname = swift-bin
diff --git a/PKGBUILD b/PKGBUILD
index aa429a3c6ba6..af2121e63a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Frederic Bezies <fredbezies at gmail dot com>, youngunix <>
pkgname=swift-bin
-pkgver=5.4
+pkgver=5.4.2
pkgrel=1
pkgdesc="Binary builds of the Swift programming language"
arch=('x86_64')
url="https://swift.org"
license=('apache')
depends=('libutil-linux' 'libxml2' 'python36')
-makedepends=('patchelf' 'rpmextract')
+makedepends=('patchelf')
options=('!strip')
provides=('swift-language')
replaces=('swift-language-bin')
source=("https://swift.org/builds/swift-$pkgver-release/centos8/swift-$pkgver-RELEASE/swift-$pkgver-RELEASE-centos8.tar.gz")
-sha256sums=('f282aec33e1d2c74f1b5804eb437688c39406ad21511b8ee93cec5262c921cfe')
+sha256sums=('48997efc0d3b5a87082609b2d2bab21e421e711427386def6b6e761e5491167f')
package() {
find_elf_only() {