summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Gonzalez2020-10-25 20:36:22 -0500
committerRyan Gonzalez2020-10-25 20:39:27 -0500
commitc11c5ce14def8ed0e70a6ebd093afc7bb0c35293 (patch)
tree06b441341970ce85534f0d6d0f55a563a91fe548
parentfbed243a1cdb190d9d917a1d0adb73b95d563ee6 (diff)
downloadaur-c11c5ce14def8ed0e70a6ebd093afc7bb0c35293.tar.gz
Updates
- Drop conflicts with swift-language-git - Add ld.so.conf
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6beb3c5f14fb..7afd75a63f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swift-bin
pkgdesc = Binary builds of the Swift programming language
pkgver = 5.3
- pkgrel = 1
+ pkgrel = 2
url = https://swift.org
arch = x86_64
license = apache
@@ -11,7 +11,6 @@ pkgbase = swift-bin
depends = libxml2
depends = python2
provides = swift-language
- conflicts = swift-language-git
replaces = swift-language-bin
options = !strip
source = https://swift.org/builds/swift-5.3-release/centos8/swift-5.3-RELEASE/swift-5.3-RELEASE-centos8.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index d358202c49ae..67330152a8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgname=swift-bin
pkgver=5.3
-pkgrel=1
+pkgrel=2
pkgdesc="Binary builds of the Swift programming language"
arch=('x86_64')
url="https://swift.org"
license=('apache')
depends=('libutil-linux' 'libxml2' 'python2')
makedepends=('patchelf' 'rpmextract')
-conflicts=('swift-language-git')
options=('!strip')
provides=('swift-language')
replaces=('swift-language-bin')
@@ -41,4 +40,7 @@ package() {
patchelf+=(--replace-needed "lib${lib}.so.6" "lib${lib}w.so")
done
find_elf_only -exec "${patchelf[@]}" {} \;
+
+ install -dm755 "${pkgdir}/etc/ld.so.conf.d"
+ echo '/usr/lib/swift/lib/swift/linux' >> "${pkgdir}/etc/ld.so.conf.d/swift.conf"
}