summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Gonzalez2018-03-30 13:36:14 -0500
committerRyan Gonzalez2018-03-30 13:36:14 -0500
commitdcca57773b0c9baaa7cec0b147a490c41d33485a (patch)
tree0ea15b3f864529600057525423b84dbc7b3d1bf6
parent0fa1569e218cb0c5e8a1bd48367bd33af1ad27eb (diff)
downloadaur-dcca57773b0c9baaa7cec0b147a490c41d33485a.tar.gz
Swift 4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62f37777502f..696f59505e3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swift-bin
pkgdesc = Official binary builds of the Swift programming language.
- pkgver = 4.0.3
- pkgrel = 5
+ pkgver = 4.1
+ pkgrel = 1
url = https://swift.org
arch = x86_64
license = apache
@@ -23,10 +23,10 @@ pkgbase = swift-bin
conflicts = swift-language-git
replaces = swift-language-bin
options = !strip
- source = https://swift.org/builds/swift-4.0.3-release/ubuntu1604/swift-4.0.3-RELEASE/swift-4.0.3-RELEASE-ubuntu16.04.tar.gz
- source = https://swift.org/builds/swift-4.0.3-release/ubuntu1604/swift-4.0.3-RELEASE/swift-4.0.3-RELEASE-ubuntu16.04.tar.gz.sig
+ source = https://swift.org/builds/swift-4.1-release/ubuntu1604/swift-4.1-RELEASE/swift-4.1-RELEASE-ubuntu16.04.tar.gz
+ source = https://swift.org/builds/swift-4.1-release/ubuntu1604/swift-4.1-RELEASE/swift-4.1-RELEASE-ubuntu16.04.tar.gz.sig
validpgpkeys = 5E4DF843FB065D7F7E24FBA2EF5430F071E1B235
- sha256sums = 9adf64cabc7c02ea2d08f150b449b05e46bd42d6e542bf742b3674f5c37f0dbf
+ sha256sums = bd11d422d466dc8fc149e52c4a4a94aa56dc5f03520f482fba5cd7e58f15bbc4
sha256sums = SKIP
pkgname = swift-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4a5fcdcb1777..360718d2b903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Ryan Gonzalez <rymg19 at gmail dot com>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>, youngunix <>
-_version=4.0.3
+_version=4.1
pkgname=swift-bin
pkgver=${_version//-/.}
-pkgrel=5
+pkgrel=1
pkgdesc="Official binary builds of the Swift programming language."
arch=('x86_64')
url="https://swift.org"
@@ -20,7 +20,7 @@ source=(
"https://swift.org/builds/swift-${_version}-release/ubuntu1604/swift-${_version}-RELEASE/swift-${_version}-RELEASE-ubuntu16.04.tar.gz"
"https://swift.org/builds/swift-${_version}-release/ubuntu1604/swift-${_version}-RELEASE/swift-${_version}-RELEASE-ubuntu16.04.tar.gz.sig"
)
-sha256sums=('9adf64cabc7c02ea2d08f150b449b05e46bd42d6e542bf742b3674f5c37f0dbf'
+sha256sums=('bd11d422d466dc8fc149e52c4a4a94aa56dc5f03520f482fba5cd7e58f15bbc4'
'SKIP')
package() {
@@ -47,7 +47,7 @@ package() {
# Patch the ld interpreter to avoid version warnings
qldv "`qldv -find`" "${target}/lib/ld.so"
- find "${target}/bin" -type f -exec patchelf --set-interpreter '/usr/lib/swift/lib/ld.so' {} \;
+ find "${target}/bin" -type f -not -name liblldb-intel-mpxtable.so -exec patchelf --set-interpreter '/usr/lib/swift/lib/ld.so' {} \;
# Hack to override Clang and ensure Swift runs patchelf on output files to fix the libcurl version warnings
echo '#!/bin/bash' > "${target}/bin/clang++"