summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Towns2015-12-21 21:49:07 +1100
committerAshley Towns2015-12-21 21:49:07 +1100
commitb9db77630aaa29c1a51cd40da4d1b0bf5f878a11 (patch)
tree7885b8290d43479c43f623236906fba8a4c98a0c
parent586a04d42f3b256a8cade6f835f84ccff13cee29 (diff)
downloadaur-b9db77630aaa29c1a51cd40da4d1b0bf5f878a11.tar.gz
2015-12-18a snapshot and fixes
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9cae5aa97b4..29b8dede99fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 21:56:07 UTC 2015
+# Mon Dec 21 10:48:27 UTC 2015
pkgbase = swift-bin
pkgdesc = The Swift programming language, the binary drops from the official website
- pkgver = 2.2.SNAPSHOT.2015.12.10.a
+ pkgver = 2.2.SNAPSHOT.2015.12.18.a
pkgrel = 1
url = https://swift.org
arch = x86_64
@@ -15,14 +15,15 @@ pkgbase = swift-bin
depends = libbsd
depends = clang
depends = libtinfo
+ depends = python2-six
provides = swift-language
conflicts = lldb
conflicts = swift-language-git
replaces = swift-language-bin
options = !strip
- source = https://swift.org/builds/ubuntu1510/swift-2.2-SNAPSHOT-2015-12-10-a/swift-2.2-SNAPSHOT-2015-12-10-a-ubuntu15.10.tar.gz
- source = https://swift.org/builds/ubuntu1510/swift-2.2-SNAPSHOT-2015-12-10-a/swift-2.2-SNAPSHOT-2015-12-10-a-ubuntu15.10.tar.gz.sig
- sha256sums = ee518e50c6bbc414980ea2a58dfe0d41a76068dba2cff718430164089d998abc
+ source = https://swift.org/builds/ubuntu1510/swift-2.2-SNAPSHOT-2015-12-18-a/swift-2.2-SNAPSHOT-2015-12-18-a-ubuntu15.10.tar.gz
+ source = https://swift.org/builds/ubuntu1510/swift-2.2-SNAPSHOT-2015-12-18-a/swift-2.2-SNAPSHOT-2015-12-18-a-ubuntu15.10.tar.gz.sig
+ sha256sums = 350e096af4ed051574021fe8bc7c90ac1087fb0e749b6f2c11f7c83a6674a62e
sha256sums = SKIP
pkgname = swift-bin
diff --git a/PKGBUILD b/PKGBUILD
index d9ea96f12f2a..7559a5ce6686 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ashley Towns <mail(at)ashleytowns(dot)id(dot)au>
-_version=2.2-SNAPSHOT-2015-12-10-a
+_version=2.2-SNAPSHOT-2015-12-18-a
pkgname=swift-bin
pkgver=${_version//-/.}
@@ -9,7 +9,7 @@ pkgdesc="The Swift programming language, the binary drops from the official webs
arch=('x86_64')
url="https://swift.org"
license=('apache')
-depends=('icu55' 'ncurses5-compat-libs' 'libedit' 'python2' 'libutil-linux' 'libbsd' 'clang' 'libtinfo')
+depends=('icu55' 'ncurses5-compat-libs' 'libedit' 'python2' 'libutil-linux' 'libbsd' 'clang' 'libtinfo' 'python2-six')
conflicts=('lldb' 'swift-language-git')
options=('!strip')
validpgpkeys=('7463A81A4B2EEA1B551FFBCFD441C977412B37AD')
@@ -20,7 +20,7 @@ source=(
"https://swift.org/builds/ubuntu1510/swift-${_version}/swift-${_version}-ubuntu15.10.tar.gz"
"https://swift.org/builds/ubuntu1510/swift-${_version}/swift-${_version}-ubuntu15.10.tar.gz.sig"
)
-sha256sums=('ee518e50c6bbc414980ea2a58dfe0d41a76068dba2cff718430164089d998abc'
+sha256sums=('350e096af4ed051574021fe8bc7c90ac1087fb0e749b6f2c11f7c83a6674a62e'
'SKIP')
package() {
@@ -36,6 +36,14 @@ package() {
find "${pkgdir}/usr/bin" -type f -exec sed -i 's/libedit\.so\.2/libedit\.so\.0/g' {} \;
find "${pkgdir}/usr/lib" -type f -exec sed -i 's/libedit\.so\.2/libedit\.so\.0/g' {} \;
+ # remove the six.py dumped in python's site packages
+ rm "${pkgdir}/usr/lib/python2.7/site-packages/six.py"
+
+ # Ensure the items have the right permissions..
+ # some tarballs from upstream seem to have the wrong ones
+ find "${pkgdir}/usr/bin" -type f -exec chmod a+rx {} \;
+ find "${pkgdir}/usr/lib" -type f -exec chmod a+r {} \;
+
# Update glibc map paths
sed -i 's/\/x86_64-linux-gnu//g' "${pkgdir}/usr/lib/swift/glibc/module.map"