summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-10-30 06:52:24 +0100
committersoloturn2023-10-30 06:54:22 +0100
commit08cfbcc544e1d5ce44d8c8fc8d6f4c226c628fcf (patch)
treedea21e114de90972fcbe635819d667cbfd559f0c
parentf0573207fa3c7342298c0224b8b76536a27a8f4e (diff)
downloadaur-08cfbcc544e1d5ce44d8c8fc8d6f4c226c628fcf.tar.gz
remove stdint patch
-rw-r--r--.SRCINFO2
-rw-r--r--0002-stdint.patch12
-rw-r--r--PKGBUILD3
3 files changed, 0 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a2caa8c8351..47df2eac3ae2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,7 +35,6 @@ pkgbase = swift-language
source = swift-integration-tests::git+https://github.com/apple/swift-integration-tests#tag=swift-5.9-RELEASE
source = apple-llvm-project::git+https://github.com/apple/llvm-project#tag=swift-5.9-RELEASE
source = 0001-arch-aur-patches.patch
- source = 0002-stdint.patch
source = indexstore-db::git+https://github.com/apple/indexstore-db#tag=swift-5.9-RELEASE
source = yams::git+https://github.com/jpsim/Yams#tag=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#tag=swift-5.9-RELEASE
@@ -95,6 +94,5 @@ pkgbase = swift-language
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = swift-language
diff --git a/0002-stdint.patch b/0002-stdint.patch
deleted file mode 100644
index f18fd140620c..000000000000
--- a/0002-stdint.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/llvm/include/llvm/Support/Signals.h b/llvm/include/llvm/Support/Signals.h
-index 44f5a750ff5..937e0572d4a 100644
---- a/llvm/include/llvm/Support/Signals.h
-+++ b/llvm/include/llvm/Support/Signals.h
-@@ -14,6 +14,7 @@
- #ifndef LLVM_SUPPORT_SIGNALS_H
- #define LLVM_SUPPORT_SIGNALS_H
-
-+#include <cstdint>
- #include <string>
-
- namespace llvm {
diff --git a/PKGBUILD b/PKGBUILD
index 16f7549db464..eae47232e965 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,6 @@ source=(
"swift-integration-tests::git+https://github.com/apple/swift-integration-tests#tag=${_swiftver}"
"apple-llvm-project::git+https://github.com/apple/llvm-project#tag=${_swiftver}"
"0001-arch-aur-patches.patch"
- "0002-stdint.patch"
# swift src to check afterwards
"indexstore-db::git+https://github.com/apple/indexstore-db#tag=${_swiftver}"
"yams::git+https://github.com/jpsim/Yams#tag=5.0.1"
@@ -96,7 +95,6 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
@@ -108,7 +106,6 @@ sha256sums=(
options=(!strip)
prepare () {
- ( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-patches.patch" )
( cd apple-llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
}