summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-02-02 03:10:52 +0100
committersoloturn2023-02-02 03:10:52 +0100
commit56481eb08c4f242d13c82274f0384769d2657620 (patch)
tree1b43d7ea949644dd3ffe3d5b11d30ec379ca76e7
parentf4db613792accb5fbd84102cf45ad2871d8e0d05 (diff)
downloadaur-56481eb08c4f242d13c82274f0384769d2657620.tar.gz
inline versions
-rw-r--r--PKGBUILD27
1 files changed, 9 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbb7d6c72e1f..3a50f45bcf7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,6 @@ pkgname=swift-language
_swiftver=swift-5.7.3-RELEASE
pkgver=5.7.3
pkgrel=1
-swiftargumentparserver=1.0.3
-swiftatomicsver=1.0.2
-swiftcollectionsver=1.0.1
-swiftcryptover=1.1.5
-swiftniover=2.31.2
-swiftniosslver=2.15.0
-swiftnumericsver=1.0.1
-swiftsystemver=1.1.1
-yamsver=5.0.0
pkgdesc="The Swift programming language and debugger"
arch=('x86_64')
@@ -30,7 +21,7 @@ source=(
"git+https://github.com/apple/swift#tag=${_swiftver}"
"cmark::git+https://github.com/apple/swift-cmark#tag=${_swiftver}"
"llbuild::git+https://github.com/apple/swift-llbuild#tag=${_swiftver}"
- "swift-argument-parser::git+https://github.com/apple/swift-argument-parser#tag=${swiftargumentparserver}"
+ "swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.0.3"
"swift-driver::git+https://github.com/apple/swift-driver#tag=${_swiftver}"
"swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#tag=${_swiftver}"
"swiftpm::git+https://github.com/apple/swift-package-manager#tag=${_swiftver}"
@@ -44,22 +35,22 @@ source=(
"0001-arch-aur-patches.patch"
# swift src to check afterwards
"indexstore-db::git+https://github.com/apple/indexstore-db#tag=${_swiftver}"
- "yams::git+https://github.com/jpsim/Yams#tag=${yamsver}"
+ "yams::git+https://github.com/jpsim/Yams#commit=5.0.0"
"sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#tag=${_swiftver}"
- "swift-atomics::git+https://github.com/apple/swift-atomics#tag=${swiftatomicsver}"
+ "swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2"
"swift-cmark-gfm::git+https://github.com/apple/swift-cmark#tag=${_swiftver}"
- "swift-collections::git+https://github.com/apple/swift-collections#tag=${swiftcollectionsver}"
- "swift-crypto::git+https://github.com/apple/swift-crypto#tag=${swiftcryptover}"
+ "swift-collections::git+https://github.com/apple/swift-collections#commit=1.0.1"
+ "swift-crypto::git+https://github.com/apple/swift-crypto#commit=1.1.5"
"swift-docc::git+https://github.com/apple/swift-docc#branch=main"
"swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main"
"swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main"
"swift-format::git+https://github.com/apple/swift-format#tag=${_swiftver}"
"swift-installer-scripts::git+https://github.com/apple/swift-installer-scripts#branch=main"
"swift-markdown::git+https://github.com/apple/swift-markdown#tag=${_swiftver}"
- "swift-nio::git+https://github.com/apple/swift-nio#tag=${swiftniover}"
- "swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#tag=${swiftniosslver}"
- "swift-numerics::git+https://github.com/apple/swift-numerics#tag=${swiftnumericsver}"
- "swift-system::git+https://github.com/apple/swift-system#tag=${swiftsystemver}"
+ "swift-nio::git+https://github.com/apple/swift-nio#commit=2.31.2"
+ "swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#commit=2.15.0"
+ "swift-numerics::git+https://github.com/apple/swift-numerics#commit=1.0.1"
+ "swift-system::git+https://github.com/apple/swift-system#commit=1.1.1"
"swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#tag=${_swiftver}"
"swift-xcode-playground-support::git+https://github.com/apple/swift-xcode-playground-support#tag=${_swiftver}"
)