summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-05-20 12:45:14 +0200
committersoloturn2023-05-20 12:45:14 +0200
commit8f4275f912951f22e0f06b157a199542e1e7c01b (patch)
tree187e130fc57689353d03d5f34b1d45dc0675c7a0
parentc37aaf469809ae352c37d143293ad8236d7090e0 (diff)
downloadaur-8f4275f912951f22e0f06b157a199542e1e7c01b.tar.gz
patch llvm-project Signals.h
bring commit: https://github.com/llvm/llvm-project/commit/ff1681ddb303223973653f7f5f3f3435b48a1983 from llvm-project upstream. ticket in apple/llvm-project: https://github.com/apple/llvm-project/issues/6847
-rw-r--r--0002-stdint.patch12
-rw-r--r--PKGBUILD3
2 files changed, 15 insertions, 0 deletions
diff --git a/0002-stdint.patch b/0002-stdint.patch
new file mode 100644
index 000000000000..f18fd140620c
--- /dev/null
+++ b/0002-stdint.patch
@@ -0,0 +1,12 @@
+diff --git a/llvm/include/llvm/Support/Signals.h b/llvm/include/llvm/Support/Signals.h
+index 44f5a750ff5..937e0572d4a 100644
+--- a/llvm/include/llvm/Support/Signals.h
++++ b/llvm/include/llvm/Support/Signals.h
+@@ -14,6 +14,7 @@
+ #ifndef LLVM_SUPPORT_SIGNALS_H
+ #define LLVM_SUPPORT_SIGNALS_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace llvm {
diff --git a/PKGBUILD b/PKGBUILD
index 8de99ff8ff5c..b6844c1401aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,6 +33,7 @@ source=(
"swift-integration-tests::git+https://github.com/apple/swift-integration-tests#tag=${_swiftver}"
"llvm-project::git+https://github.com/apple/llvm-project#tag=${_swiftver}"
"0001-arch-aur-patches.patch"
+ "0002-stdint.patch"
# swift src to check afterwards
"indexstore-db::git+https://github.com/apple/indexstore-db#tag=${_swiftver}"
"yams::git+https://github.com/jpsim/Yams#tag=5.0.1"
@@ -92,6 +93,7 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
@@ -104,6 +106,7 @@ options=(!strip)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-patches.patch" )
+ ( cd llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
}
#pkgver() {