summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-05-12 07:47:41 +0200
committersoloturn2023-05-12 11:25:08 +0200
commitc37aaf469809ae352c37d143293ad8236d7090e0 (patch)
tree513f3a800aee22d4c9d2df91d278e599c84b9bcd
parent4ea6a7f7123872ed474471d309d59f6afba3856c (diff)
downloadaur-c37aaf469809ae352c37d143293ad8236d7090e0.tar.gz
update to 5.8
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fc157ce7519..8de99ff8ff5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language
-_swiftver=swift-5.7.3-RELEASE
-pkgver=5.7.3
+_swiftver=swift-5.8-RELEASE
+pkgver=5.8.0
pkgrel=1
pkgdesc="The Swift programming language and debugger"
@@ -35,17 +35,18 @@ source=(
"0001-arch-aur-patches.patch"
# swift src to check afterwards
"indexstore-db::git+https://github.com/apple/indexstore-db#tag=${_swiftver}"
- "yams::git+https://github.com/jpsim/Yams#tag=5.0.0"
+ "yams::git+https://github.com/jpsim/Yams#tag=5.0.1"
"sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#tag=${_swiftver}"
"swift-atomics::git+https://github.com/apple/swift-atomics#tag=1.0.2"
"swift-cmark-gfm::git+https://github.com/apple/swift-cmark#tag=${_swiftver}"
"swift-collections::git+https://github.com/apple/swift-collections#tag=1.0.1"
- "swift-crypto::git+https://github.com/apple/swift-crypto#tag=1.1.5"
- "swift-docc::git+https://github.com/apple/swift-docc#branch=main"
- "swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main"
- "swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main"
+ "swift-crypto::git+https://github.com/apple/swift-crypto#tag=2.2.3"
+ "swift-docc::git+https://github.com/apple/swift-docc#tag=${_swiftver}"
+ "swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#tag=${_swiftver}"
+ "swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#tag=${_swiftver}"
"swift-format::git+https://github.com/apple/swift-format#tag=${_swiftver}"
- "swift-installer-scripts::git+https://github.com/apple/swift-installer-scripts#branch=main"
+ "swift-installer-scripts::git+https://github.com/apple/swift-installer-scripts#tag=${_swiftver}"
+ "swift-lmdb::git+https://github.com/apple/swift-lmdb#tag=${_swiftver}"
"swift-markdown::git+https://github.com/apple/swift-markdown#tag=${_swiftver}"
"swift-nio::git+https://github.com/apple/swift-nio#tag=2.31.2"
"swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#tag=2.15.0"
@@ -90,6 +91,7 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)